Established Member.. Nilay___
Established Member..
1075 views

SSL Configuration

Jump to solution

hi,

i defined following parameters and their information in server.conf file to configure SSL. Then i run sh kUpdateHtml and start ppm server. After SSL configuration i can open ppm page like https://name.com.tr  but can not pass the logün page. I log admin username and password but login page can't direct me to main ppm page.

Is there any extra parameters i need to define, or give any access or privileges for server ip.

 

 

com.kintana.core.server.ENABLE_SSL_LOGIN

com.kintana.core.server.HTTPS_PORT

com.kintana.core.server.HTTPS_WEB_THREAD_MIN

com.kintana.core.server.HTTPS_WEB_THREAD_MAX

com.kintana.core.server.HTTPS_KEYSTORE_LOCATION

com.kintana.core.server.HTTPS_KEYPASSWORD

com.kintana.core.server.BASE_URL

 

thanks.

Tags (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Established Member.. Nilay___
Established Member..

Re: SSL Configuration

Jump to solution

hi,

 

i found the reason why this problem occurs. Server.conf BASE_URL parameter needs to be defined without any port number just like http://xxx.aaa.com.tr   (wrong definiton was following--> http://xxx.aaa.com.tr:8080)

 

After i changed base url definiton problem fixed, but another problem occured unfortunately. In login page i log ppm username and password than submit but it takes over 1 or 1.5 minutes to direct ppm frontpage, but system returns its normal behaviour after i direct front page all dashboard modules runs quickly. Why could be the reason of slow login? Could it caused by SSL port 443?

View solution in original post

0 Likes
4 Replies
Celil Absent Member.
Absent Member.

Re: SSL Configuration

Jump to solution
Hi Nilay,

book PPM9.10_InstallationAdmin page 109. Did you follow the this checklist?
Celil

IT Governance Professional
& PPM Solution Architect
0 Likes
Established Member.. Nilay___
Established Member..

Re: SSL Configuration

Jump to solution

hi Celil:)

 

i checked all parameter one by one from installation admin guide,

to make my mind clear there was one more parameter HTTPS_PROTOCOL (default value =TLS), and changed it from default value TLS to SSL.But it makes no changes to result. Still i can open ppm login page but when i enter user name and password and submit, a blank page opens and directs to itself continuously, like some kind of loop.

 

0 Likes
Highlighted
Established Member.. Nilay___
Established Member..

Re: SSL Configuration

Jump to solution

hi,

 

i found the reason why this problem occurs. Server.conf BASE_URL parameter needs to be defined without any port number just like http://xxx.aaa.com.tr   (wrong definiton was following--> http://xxx.aaa.com.tr:8080)

 

After i changed base url definiton problem fixed, but another problem occured unfortunately. In login page i log ppm username and password than submit but it takes over 1 or 1.5 minutes to direct ppm frontpage, but system returns its normal behaviour after i direct front page all dashboard modules runs quickly. Why could be the reason of slow login? Could it caused by SSL port 443?

View solution in original post

0 Likes
Established Member.. Nilay___
Established Member..

Re: SSL Configuration

Jump to solution
hi all,
we fixed slowness problem either. Standart PPM dashboard's request list portlet's causes slow login.
To create a blank dashboard page and setting it as default page after login accelerates system login.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.