Absent Member.. Niraj Prabhu Absent Member..
Absent Member..

Re: Table Component Updates

Vamsee,
Do you have error log when this execution step is getting executed? I am interested to see if the folder structure is different for your bin folder.
Also, can you VERIFY the environment PPM_TEST. This execution step picks up the environment definition to login to the server before executing the sh command. Share the screenshot if it is failing.
Niraj P.
Peter Zehrer Absent Member.
Absent Member.

Re: Table Component Updates

I am not getting any error log and i did verify PPM_TEST its working fine.

 

Thanks,

Vamsee.

0 Likes
Absent Member.. Niraj Prabhu Absent Member..
Absent Member..

Re: Table Component Updates

Vamsee,
Are you saying that the execution step is failing with no error? What do you mean when you say it is not working?

Share the graphical view and request status to help me understand if the request is stuck at this execution step.
Niraj P.
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Table Component Updates

Try removing the spaces around the = on the ksc_connect_source_server command:

 

ksc_connect_source_server SOURCE_ENV="KINTANA_SERVER"

 

Also, specify a path for the script in case the current working directory is not in the path variable:

 

sh ./kRunCacheManager.sh A

Peter Zehrer Absent Member.
Absent Member.

Re: Table Component Updates

Hi Niraj,

 

I checked in the log it says that Refused to connect. Attached is the log file error message.

 

And when try to use the command  ksc_local_exec "cd bin;sh ./kRunCacheManager.sh A" itsthrowing an error "cannot find the file specified". Attached is log.

 

Thanks,

Vamsee.

 

 

0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Table Component Updates

The error message in the log is:

 

Cannot run program "sh": CreateProcess error=2, The system cannot find the file specified

 

If the sh command cannot be found, there are some serious basic configuration problems in your environment. Try executing the following command before this commands to see what the PATH variable contains and what the default working directory is:

 

ksc_local_exec echo $PATH

ksc_local_exec pwd

 

The connection refused messages appear to be related to the smtp server, probably for sending notifications. They should not be related to the problems with executing these commands.

0 Likes
Absent Member.. Niraj Prabhu Absent Member..
Absent Member..

Re: Table Component Updates

Vamsee,

Can you share the screenshot of the sh kCacheManager.sh A command execution from your shell prompt? You have mentioned in this posting that you have to do that each time the table component is updated. I would like to see how you do that? the screeshot should help us see the directory that you go to. Also execute pwd before executing the sh kRunCacheManager.sh command.
Niraj P.
Peter Zehrer Absent Member.
Absent Member.

Re: Table Component Updates

Hi Niraj,

 

I have attached the screenshot of cachemanager and also the log after i modified the Cleae Cache execution step attached the same. Please let me know your mail id i can mail you the details needed further.


Thanks,

Vamsee.

0 Likes
Erik Cole Acclaimed Contributor.
Acclaimed Contributor.

Re: Table Component Updates

Often you can avoid the stale cache issues by including values for LAST_UPDATE_DATE AND LAST_UPDATED_BY on whatever entities you are updating. It's been a while since I've worked with table components, but you might try updating these values for kcrt_table_entries and also kcrt_request_details and kcrt_requests for that same request_id. Usually, that forces a refresh of the request in the front end without having to run the cache manager shell script...

0 Likes
Peter Zehrer Absent Member.
Absent Member.

Re: Table Component Updates

Hi,

 

Updating kcrt_table_entries table did not work.

 

I have included all the tables as suggested in the function but it did not work.

 

Thanks,

Vamsee.

0 Likes
Highlighted
Absent Member.. Niraj Prabhu Absent Member..
Absent Member..

Re: Table Component Updates

Vamsee,

 

Please do you have support case with HP already? They should be able to look at your configuration more closely and provide solution. Let us know if you need any additional help on resolving this.

 

Niraj P.
Peter Zehrer Absent Member.
Absent Member.

Re: Table Component Updates

Hi Niraj,

 

You said in your previous message that there are few basic configuration settings which are incorrect can you please let me know those settings and would it be possibe for you to have a webex session for 30 minutes to go thorigu the settings. please let me know. You can mail me to vamsee.maradugu@invesco.com

 

Thanks,

Vamsee.

0 Likes
Peter Zehrer Absent Member.
Absent Member.

Re: Table Component Updates

Hi Jim,

 

Please let me know if we can have a webex to through the configuration settings as you said. You can mailme on vamsee.maradugu@invesco.com

 

Thanks,

Vamsee.

0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Table Component Updates

It looks like you are running on Windows. We use AIX and I have no experience running PPM on Windows. I would suggest reviewing everything in the Installation and Administration Guide concerning configuring on Windows. If that doesn't lead to a resolution, you should open a case with HP.

0 Likes
Absent Member.. AlexSavencu Absent Member..
Absent Member..

Re: Table Component Updates

Hi,

 

you said that you updated the tables and it did not work.

 

What exactly did not work? How did you insert data? was there any error? Was the data not shown in the request?

 

cheers

alex


--remember to kudos people who helped solve your problem
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.