Absent Member.. b460 Absent Member..
Absent Member..
60 views

Tokens not resolving in execution step

Hi,

We have a request that has a field which is autmoatically populated with the result of a rule that is triggered.

When we try to use this field in an execution step by referencing the token to compare values it seems that the token is always null.

Does anyone know why when a field is populated from the result of a rule, its token is null and if there is anyway to get around this so the token contains the correct token so it can be resolved correctly?
0 Likes
12 Replies
Mahen M Frequent Contributor.
Frequent Contributor.

Re: Tokens not resolving in execution step

can you attach the snap of the execution step?

Regards,
Mahendran M
0 Likes
Absent Member.. b460 Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

Please see the attached screenshot of the execution step.
0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

What does the rule look like?
0 Likes
shygirl Absent Member.
Absent Member.

Re: Tokens not resolving in execution step

Have you tried capturing if the tokens have values before the request passed through the exection step?
0 Likes
Absent Member.. b460 Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

Please see attached a screenshot of the rule.

The fields in the dependencies section are populated in the following way:
- Estimate To Complete: automatically by another rule.
- Actual Expentiture To Date: manually by user input.

The rule the adds these 2 fields together and puts the result in the Estimate At Completion field.

What seems to be happening is that beacuse the Estimate At Completion field is populated by a rule, its value is not being stored in the token.

Is it possible the fields that get populated by rules, dont populate the token associated with it? How could I get around this so the token gets populated?
0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

The token is just a way to get the field value. If the field has a value, the token will get it. There are a couple of other possibilities for not getting values here:

1. Rules do not 'cascade'. If a field is changed by a rule, the change will not trigger another rule. Rules are triggered only when the field is changed by a user. You can get around this by adding a dependency on this rule for the field that triggered the change to the other field.

2. We recently upgraded to 7.5 and have discovered that now rules will not change a field if the user triggering the rule does not have access to the field. This is a change from 6.0.
0 Likes
Highlighted
Absent Member.. Linda Hauck Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

To Jim:

Regarding your statement about when you upgraded to 7.5 and then the rules wouldn't fill fields that a user doesn't have access to.
This would be very bad for us! Did you find a solution to this? We are getting ready to upgrade to 7.5->8.0

thanks!
Linda

0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

The problem concerns access based on field level security. We just identified the problem yesterday and do not have a resolution. We have seen the issue only with 7.5. It did not work this way in 6.0. We did not use 7.1 in production so I have no idea how it behaves. We have not looked at 8.0 yet.
0 Likes
Erik Cole Acclaimed Contributor.
Acclaimed Contributor.

Re: Tokens not resolving in execution step

Jim, what patch level are you on? I can't reproduce this in 7.5 sp 2 or 8.0 sp1...?
0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

We are running 7.5 SP6 with a couple of hot fixes related to validations using command with delimited output / multi-select / short list.
0 Likes
Absent Member.. b460 Absent Member..
Absent Member..

Re: Tokens not resolving in execution step

OK, back to the original post, i'll re-explain the issue to see if it comes across clearer.

So looking at the execution step (first attachment in thread).

The [REQD.P.ESTIMATE_AT_COMPLETION] field is populated by a rule and the [REQD.P.APPROVED_BUDGET] field is populated by a rule.

When the request gets to the execution step, it is always going to the 'UNDER_BUDGET' case.

If I populate these fields manually it works fine. Any ideas?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.