Govardhan07 Super Contributor.
Super Contributor.
320 views

Unable to connect new LINUX server via PPM Environment

Earlier we are using PPM environments to connect HP-UX, below one is the screenshot of it.

 

 

 Now they have migrated the application from the HP-UX to LINUX server, they setup the smae user 'itgcmsys' in the new LINUX server also with the same permissions but when we complete the Environment check for the new environment it is failed to connect and showing the error below are the screenshots of new environment and error.

Please suggest is there any things need to be included for connecting new LINUX server.

 

 

 

 

 

0 Likes
14 Replies
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: Unable to connect new LINUX server via PPM Environment

Hi Govardhan07,

 

Which version PPM are you using ?

Did you turn off Linux firewall ?

 

 

Hope this help.

 

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Govardhan07 Super Contributor.
Super Contributor.

Re: Unable to connect new LINUX server via PPM Environment

Is it mandatory to turn-off Linux firewall?

 

We are using PPM 7.5

0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: Unable to connect new LINUX server via PPM Environment

Hi,

 

I just want to check have any denied from Linux firewall or not.

One thing. Which version Linux are you using?

 

Also, i would like to tell you that you are using an unsupported PPM version. I  recommend you to make an upgrade to a supported version. This will give you more benefits because these versions have more fixes and won't give you a lot of problems like older versions.

 

Thanks.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Unable to connect new LINUX server via PPM Environment

Can you ssh to the Linux server from your application server from the command line? This will often give you more detailed information about the failure and you can enable additional debug and logging options with parameters on the ssh command.

Absent Member.. AlexSavencu Absent Member..
Absent Member..

Re: Unable to connect new LINUX server via PPM Environment

Gents,

The error is pretty clear: unknown host exception. So you have to make sure that the host name is correct and that it is accessible from the source box.

Cheers
Alex

--remember to kudos people who helped solve your problem
Govardhan07 Super Contributor.
Super Contributor.

Re: Unable to connect new LINUX server via PPM Environment

After some changes to server name, we are able to connect the LINUX server but still we are facing some issues, please refer the screenshots below.

 

The error is showing some problem with SSH authentication.

 

Please suggest.

 

 

 

0 Likes
Absent Member.. AlexSavencu Absent Member..
Absent Member..

Re: Unable to connect new LINUX server via PPM Environment

Hi,

Does the connection succeed when you do it manually? Did you set up the rsa keys properly?

I would suggest to get the Linux box admin to make sure that ssh is properly set up in both machines. Sometimes the ssh connection fails due to inappropriate permissions configured for the user's home directory and / or .ssh folder.

Cheers
Alex

--remember to kudos people who helped solve your problem
0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: Unable to connect new LINUX server via PPM Environment

Hi Govardhan07,

 

Please verify the server.conf entry SSH_PRIVATE_IDENTITY_FILE is properly configured.
Check the entry in the server.conf SSH_PRIVATE_IDENTITY_FILE points to a valid private key (RSA) file.
com.kintana.core.server.SSH_PRIVATE_IDENTITY_FILE=///.ssh/id_rsa


If the Private Key authorization with SSH has not been configured, please proceed with the following steps. This assumes that the SSH server is configured for Private Key authorization. Also, SSH server is installed and there is the ssh-keygen utility that is available on the PPM Server box.(Hope in Unix you have the key authentication)

 

Configuring Private Key Authentication with Secure Shell

This section provides information on how to configure private key authentication with secure shell (SSH). The procedure is based on the following assumptions:

- SSH is installed.
- The SSH server is configured for private key authorization.
- The ssh-keygen utility is part of the Cygwin installation. (To get this utility, you must enable the Open SSH components during Cygwin installation.)

Before you configure private key authentication, do the following:

- Verify that the PPM Center user account can be used to log on to the remote host through the SSH session.
- Add the RSA certificate information of the remote host to the ssh known_hosts file, which is located in the <PPM_Home> directory.

To add the RSA certificate of the remote SSH host to the PPM Server SSH known_hosts file:

1. Log on to the PPM Server as the PPM Center user.

2. From the command line, run the following:
ssh <User_ID>@<Remote_Host>
The first time you run this command, you are prompted to indicate whether you want to continue.

3. Type yes.

4. Terminate the SSH connection with the remote host.

To set up private key authentication with SSH:

1. Generate the private/public key pair on the PPM Server.

2. Add the generated public key to the remote SSH Authorized_Key file.

3. Configure the PPM Server.


The following sections provide the steps required to perform each of these tasks.

Generating the Private and Public Keys

To generate the private/public key pair on the PPM Server:

1. Log on to the PPM Server machine as the PPM Center user.

2. Change directory to the home directory defined for the PPM Center user on the operating system.

3. Run the following SSH utility.
ssh-keygen -t rsa -b 1024
Note: PPM Center only supports the RSA key type, and not the DSA key type.
Do not provide the “passphrase.”

4. Press Enter twice.

5. Verify that the <PPM_Home>/<PPM_User>/.ssh directory now contains the id_rsa (the private key) and id_rsa.pub (the public key) files.

Adding the Public Key to the SSH authorized_keys File on the Remote Host

To append the public key to the remote SSH authorized_keys file (remote hosts):

1. Transfer the id_rsa.pub file to the remote SSH host machine, in the /<PPM_User_Home_Directory>/.ssh directory as ppm_id_rsa.pub.
Note: On the remote UNIX host, the .ssh directory is in the /home/<PPM_User>/directory. On Windows, the location depends on the user home directory defined during Cygwin installation.

2. Log on to the remote host with the user ID that the PPM Server is to use to connect.

3. Change directory to the <PPM_Home>/<User_ID>/.ssh directory and locate the authorized_keys file.
Note: If the authorized_keys file does not exist, create it.

4. Append the contents of the itg_id_rsa.pub file to the authorized_keys file, by running the command:
cat ppm_id_rsa.pub > authorized_keys

5. Repeat these steps on the PPM Server to allow public key authentication from the PPM Server back to itself.


Configuring the PPM Server

To configure the PPM Server:

1. Open the server.conf file in a text editor such as Notepad.

2. Add the following server directive to the file.
com.kintana.core.server.SSH_PRIVATE_IDENTITY_FILE=/<PPM_Home>/<PPM_User>/.ssh/id_rsa

3. Change to the <PPM_Home>/bin directory.

4. To update the required startup files, run the kUpdateHtml.sh script.

5. Restart the PPM Server.

Verifying Server Configuration

To verify the configuration:

1. Open a command-line window outside of the PPM Server.

2. Log on to the PPM Server machine as the PPM Center user, as follows.
ssh <User_ID>@<Remote_Host>
Note: You should not be prompted for the password. It should log on to the remote host using the RSA key file.

3. On the PPM Server, log on to PPM Center.

4. From the menu bar, select Administration > Open Workbench.
The PPM Workbench opens.

5. From the shortcut bar, select Environments > Environments.
The Environment Workbench page opens.

6. Click New Environment.
The Environment: Untitled window opens.

7. In the Environment Name field, type the name of the remote host.

8. In the Server section, do the following:
a. In the Name field, type the remote server name.
b. In the Type list, select the operating system type on the remote server.
c. In the Username field, type the user ID you provided in step 2.
d. In the Password field, click the Password ( ) button.
The Enter or Change Password dialog box opens.
Note: The PPM Workbench requires that you provide a password, regardless of whether the authentication uses RSA.
e. In the Enter New Password and Confirm New Password fields, type the password for the user ID you provided in step 2.
f. Click OK.
g. In the Base Path field, type the base path.
h. In the Connection Protocol list, select SSH2.
i. In the Transfer Protocol list, select Secure Copy 2.

9. Clear the Enable Client and Enable Database checkboxes.
Note: The user name specifies the user ID to be used to log on to the destination SSH server. The Environment Checker requires the password. Package line uses the public key file for authentication.

10. Click Save.

11. At the bottom left of the window, click Check -> It should be successful.
The Check Environment window opens.

12. In the left pane, expand the Server folder, and then click SSH2 Server.

13. Click Check.
In the left pane, an icon to the left of the selected server indicates whether the check succeeded or failed. The right pane displays the details.

 

 

Hope this helps.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Govardhan07 Super Contributor.
Super Contributor.

Re: Unable to connect new LINUX server via PPM Environment

Thanks Vinhloc81, I have small doubt before completing the above process.

 

We are using HP PPM 7.5, earlier we have configured lots of deployment process for the server type 'HP-UX', 'UNIX', 'IBM AIX' using SSH2 connection protocol.

 

I checked our server.conf file there is no 'com.kintana.core.server.SSH_PRIVATE_IDENTITY_FILE=' parameter was configured for the earlier deployment process, why we need this for this deployment process?, but first time we are configuring deployment process for LINUX server (remote host), for the LINUX server is it mandatory to configure this parameter in server.conf file?

 

Please suggest.

0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: Unable to connect new LINUX server via PPM Environment

Hi,

 

That is the steps to implement the functionality.  When you Configuring Private Key Authentication with Secure Shell this step is mandatory.

 

 

Regards.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Govardhan07 Super Contributor.
Super Contributor.

Re: Unable to connect new LINUX server via PPM Environment

Sorry if I overlooked into it, then why we haven't configured server.confg with the RSA key for old deployment processes environments which I have mentioned in previous reply.

0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: Unable to connect new LINUX server via PPM Environment

Hi,

 

Im not sure how it was working before without it, but in order for SSH to work with PPM this parameter has to be present in server.conf file. You can check it in System administration guides for PPM 7.0 at page 78 i have attached for you.

 

 

Hope this helps.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Unable to connect new LINUX server via PPM Environment

 

We  have never had this value defined in our server.conf files and we successfully connect to AIX, Linux, Solaris and Windows servers with no problems. We do not use private key authentication. All of the connections are authenticated with the passwords stored in the environment definitions and the associated appcode records.

0 Likes
Govardhan07 Super Contributor.
Super Contributor.

Re: Unable to connect new LINUX server via PPM Environment

After fixing some password and user authentication problems it is successfully connecting to the remote host, without any private public key setup.

 

Anyhow thanks for all your support.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.