ShravanK Super Contributor.
Super Contributor.
721 views

Unable to see time periods in Create Time Sheet page

Hi,

We are trying to enable Time Management module. For this we have added below parameters in server.conf parameters.

But even after restarting the server ( and running updateHtml script), we are unable to see the time periods in Time Period drop down.
Please find the screenshot for the issue.

Can anyone please help me what might be the issue. Is there any other setting that we need to do to display time periods in front end.

 Below are the parameters added in server.conf file.

 

#
# Flag whether requests are allowed as work items to log time against.
#
com.kintana.core.server.ENABLE_TM_WORK_ITEM_REQUESTS=true

#
# Flag whether misc are allowed as work items to log time against.
#
com.kintana.core.server.ENABLE_TM_WORK_ITEM_MISC=true


#
#
# This settings determines the fallback view mode in which lines on a time sheet are displayed for users who haven't
# picked their preferred view mode via the Group | Ungroup Items control available on time sheets.
#
#
com.kintana.core.server.DEFAULT_TIME_SHEET_LINES_VIEW_MODE=grouped

#
# Flag whether tasks are allowed as work items to log time against.
#
com.kintana.core.server.ENABLE_TM_WORK_ITEM_TASKS=true

#
# Flag whether packages are allowed as work items to log time against.
#
com.kintana.core.server.ENABLE_TM_WORK_ITEM_PACKAGES=true

#
# Flag whether projects are allowed as work items to log time against.
#
com.kintana.core.server.ENABLE_TM_WORK_ITEM_PROJECTS=true


#
# Flag whether integration are allowed as work items to log time against.
#
com.kintana.core.server.ENABLE_TM_WORK_ITEM_EXTERNAL_DATA=true

#
# Flags for Time Management Module added by Shravan Kathuri on 05-May-2017
#

com.kintana.core.server.TMG_FUTURE_PERIODS_TO_ALLOW = 5
com.kintana.core.server.TMG_PAST_PERIODS_TO_ALLOW = 10
com.kintana.core.server.TM_DISABLE_INCLUDING_LAST_TS_ITEMS=true
com.kintana.core.server.TM_DYNAMIC_DESC_CHARS = true
com.kintana.core.server.TM_DYNAMIC_DESC_CHARS_MAX = 40
com.kintana.core.server.TM_ENABLE_GRID_RESIZE_CONTROL = true
com.kintana.core.server.TM_ENABLE_REQ_ACTIVITY_CONTROLS = false
com.kintana.core.server.TM_ENABLE_SHOW_WHATS_NEW = true
com.kintana.core.server.TM_MAX_PREVIOUS_TIME_PERIODS = 4

 


Best Regards,
Shravan

0 Likes
3 Replies
ShravanK Super Contributor.
Super Contributor.

Re: Unable to see time periods in Create Time Sheet page

Capture1.JPG

0 Likes
Outstanding Contributor.. Amishra Outstanding Contributor..
Outstanding Contributor..

Re: Unable to see time periods in Create Time Sheet page

Guess you need to enable time periods, see installation guide to run - kEnableTimeMgmtPeriodType.sh

Try  this is non prod instance first.

 

Cheers,

Ajay

 

 

Regards,
Ajay Mishra
Tags (1)
nagarajub
Visitor.

Re: Unable to see time periods in Create Time Sheet page

Shravan Anna, I think time periods are not existing in DB.. In front end it should show total 15 time periods(Past 10 and Future 5 as per your parameters added in server.conf file.)Try to see time periods in DB with query and Check the LAST period end date..

SELECT * FROM ktmg_periods 

and if not existing  please create time periods in PPM based upon the above query result(LAST period end date.)

sh kGenTimeMgmtPeriods.sh –h

Thanks,

Nagaraz

 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.