Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Absent Member.. Ramazan1 Absent Member..
Absent Member..
291 views

Why error message at some attachment fields in the portlet request list

Jump to solution

Hi,

 

there is a standard portlet by HP which is called "Request List". When I add some attachment fields I get a result and at some attachment fields I get an error message:

 

An unknown error has occurred. For more information, please contact your PPM administrator and provide the following GUID number: GUID=C19421FF-3B56-B65B-C416-F8D2FD13E668

 

In the screenshot I have two attachment fields. one of them is created in the Request Types and one of them in the Request Header Types. First I assumed it might be a problem because of Request Types or Request Header Types. But it wasn't it!

 

Do you have an idea why I get the error message?

 

thank you,

Ramazan

0 Likes
1 Solution

Accepted Solutions
mike_se Contributor.
Contributor.

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hi Ramazan,

 

I did some more research and I believe you are running in to a Defect.

 

See KM00377933. Basically, it is the Token's Name for the Attachment Field that is the issue (not the data, sorry about that). So in the STAGE environment, try shortening the Request Type's Attachment Field's Token and see if everything works as expected.

 

What version are you testing on? What is the Attachment Field's Token's Name?

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
9 Replies
Absent Member.. favdjiev Absent Member..
Absent Member..

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hi,

 

Could you please post the error you are receiving? Please add a screenshot of it and an error trace. We need it to be able to identify for certain what problem is occuring. Thank you in advance.

 

Best Regards,

Filip

0 Likes
Highlighted
Absent Member.. Ramazan1 Absent Member..
Absent Member..

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hello Filip,

 

attached you will find the screenshot of the error.

What is an error trace? Is it the log file?

 

Regards,

Ramazan

0 Likes
mike_se Contributor.
Contributor.

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hi Ramazan,

 

The error will be in the serverLog.txt file under PPM_HOME/server/SERVER_NAME/log directory of the Node where the User is logged in. Reproduce the error, note the time, and then search for that Error ID.

 

Looking at the screenshots, there seem to be some Custom Field names as the column headers. I suspect one of those columns is causing the issue. Remove all columns in the Portlet. Add them back one-by-one until the error returns.

 

Let's see if the issue can be narrowed down to a specific Field and then see if the stack dump provides further details (NullPointerException, OutOfMemoryError, etc....).

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Absent Member.. Ramazan1 Absent Member..
Absent Member..

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hello Mike,

 

attached you will find the server.log file. 

I will heed your advice and write you back.

 

Regards,

Ramazan

0 Likes
mike_se Contributor.
Contributor.

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Oh ok, I do see an Oracle error in there:

Caused by: java.sql.SQLSyntaxErrorException: ORA-00972: identifier is too long

 

So one of the column's data is probably causing this.

 

Once the column is identified, then can check the data that is being pulled in, and which data is causing the Oracle error.

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Absent Member.. Ramazan1 Absent Member..
Absent Member..

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hello Mike,

 

so you mean the content of a column, in my case the attachment field Effort-Estiman HL, has an error causing data?!  the error causing column is in the tabel kcrt_request_types, field (visible_)parameter2

 

Attached I have an excel file exported with the names of the files. Please have a view to recognize which filename causes the error. What I have seen:

 

- 1 File with extension xlsx, the others are doc, xls, pdf

- in the names there are following characters: [space] , ( , ) , - , + , _ , # ,  & , . , German character like ä (6 times available)

- long names like

"DEM30760 - RiskPro - must have after V3.0 (Credit spread & Liquidity Ratio check) - Effort Estimation.xls"

 

In the attached excel file you see the whole attachment names.

 

Regards,

Ramazan

 

0 Likes
mike_se Contributor.
Contributor.

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hi Ramazan,

 

I did some more research and I believe you are running in to a Defect.

 

See KM00377933. Basically, it is the Token's Name for the Attachment Field that is the issue (not the data, sorry about that). So in the STAGE environment, try shortening the Request Type's Attachment Field's Token and see if everything works as expected.

 

What version are you testing on? What is the Attachment Field's Token's Name?

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Absent Member.. Ramazan1 Absent Member..
Absent Member..

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Hello Mike,

 

it works. Thank you! You are great!

Now we use v9.14.

The Tokenname was EFFORT_ESTIMATION_HL -> I changed to EFF_EST_HL -> Now it works.

 

Regards,

Ramazan

0 Likes
mike_se Contributor.
Contributor.

Re: Why error message at some attachment fields in the portlet request list

Jump to solution

Oh ok, that is good to hear.

 

Sorry I didn't get it right the first time as I thought it was fixed. I will have to do a little more testing on the 9.14.0008 to be sure.

 

Thanks for letting us know it is working now.

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.