Highlighted
SamB1984
Member.
151 views

Patch Policy Reboot Behaviour - flag to reboot not clearing when user reboots via OS

Hello everyone - first post to be gentle 😉

We have an issue within our organisation that users are not reboot or shutting down often enough so we want to utilise this function to prompt users with the timers for rebooting. (Main goal here is to allow patches to finalise). But have noticed in testing that if you reboot or shutdown outside of the ZENworks prompt (so from the start menu or anything else) the flag doesn't clear? So after rebooting or shutting down the prompt comes back with time remaining? Anyone else seen this?

We are on 17.4

0 Likes
4 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Patch Policy Reboot Behaviour - flag to reboot not clearing when user reboots via OS

At least i can't dupe this on W7-64 with a 17.4 agent. Tried bouncing the boxes via start menu and "shutdown /r", didn't make a difference whether i waited for the post-scan to finish or not. Maybe OS-related. Do you see this behaviour regardless of the local rights the logged in user has?

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Patch Policy Reboot Behaviour - flag to reboot not clearing when user reboots via OS

If they are behind enough on patches, it may take a couple reboots for all the patches apply.

This is even more true on Windows 7.

0 Likes
SamB1984
Member.

Re: Patch Policy Reboot Behaviour - flag to reboot not clearing when user reboots via OS

Thanks for the replies

I have actually tried in the past with older versions of the agent but have always seen this behaviour and then ended up ditching the idea.

It doesn't matter who is logged in or the OS nor the amount of patches, on my Win10 device which is fully patched, when the next release comes the patch policy updates and it applies via the sandbox testing and it did it again on my device and colleagues in the office who are also testing this again for me.

If you reboot/shutdown outside of the zen dialog it doesn't acknowledge its been rebooted and still prompts and i 'think' it doesn't actually go through the motions of actually applying the update on restart/shutdown

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Patch Policy Reboot Behaviour - flag to reboot not clearing when user reboots via OS

Probably best to open an SR and have someone walk through the process with you.....

Perhaps you are confusing the Prompt regarding the "Permission" to install versus a "Prompt to Reboot" after the patches have been applied.  But there will only be a prompt to reboot post install when patches that require a reboot to complete are installed. 

It is possible for some reason some patch is not properly detecting that is installed and constantly re-installing, but that would be a different issues.  One thing that can cause his is a bad software installer that backdates core OS files.  It's rare, but I've seen vendors include "Updated" Core OS files in their installer....but of course in a few months they are now outdated and "undo" Windows patches when installed.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.