Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Highlighted
Frequent Contributor.. Bob_H Frequent Contributor..
Frequent Contributor..
410 views

PPM 9.3 not starting

Jump to solution

Hello!  I am trying to install PPM 9.30 in our lab, just a single server, Windows 2008, Oracle DB.  The install goes fine with no errors, but the application will not start.

 

If you try to start the Windows service, you get:

 

Windows could not start the HP PPM <PPMname> service on <servername>.

Error 83: Fail on INT24.

 

No logs are generated.  When I try to use kstart.sh via Cygwin I get output in the log files and I see:

 

 

STATUS server:localhost-startStop-1:(Server.java:534):2014/11/17-11:19:40.758 EST: Server is starting in standalone mode

 

STATUS server:localhost-startStop-1:(Server.java:973):2014/11/17-11:19:40.790 EST: Starting RMI on port 1099

 

STATUS server:localhost-startStop-1:(Server.java:641):2014/11/17-11:19:40.805 EST: HP Project and Portfolio Management v9.30

 

STATUS server:localhost-startStop-1:(Server.java:647):2014/11/17-11:19:40.946 EST: Local IP address = <myserverIP>

 

ERROR server:localhost-startStop-1:(Server.java:662):2014/11/17-11:19:44.211 EST: Administrator or Configuration License is not found.

 

ERROR server:localhost-startStop-1:(ServerStartListener.java:63):2014/11/17-11:19:44.258 EST: An error occured while starting the Kintana server.

 

This is just the last few lines of output and in all output I took out server names and IP's. the Node Sanity passed before this and I see no other errors before this.

 

Anybody seen this type of error?  Thanks!

 

Bob

 

Tags (1)
0 Likes
1 Solution

Accepted Solutions
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: PPM 9.3 not starting

Jump to solution

Hi Bob,

 

After checked your logs i can saw this " ERROR server:localhost-startStop-1:(Server.java:662):2014/11/17-11:19:44.211 EST: Administrator or Configuration License is not found."

 

In order to start PPM, you have to have foundation license, admin license and configuration license, so we can see that you don't have admin lincense and configuration license installed on you PPM and this is the root case make you cannot start PPM.

 

You should ask license team again to get correct license for PPM 9.30, if you just want an license for internal use, plese as them this license:

 

HP PPM 1 User for All Modules w/Portfolio Opt. 15-Month LTU for HP Internal

 

It work for me but im not sure it work for you or not, please try that.

 

 

Hope it helps.

 

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
9 Replies
Natalia_R_PPM Absent Member.
Absent Member.

Re: PPM 9.3 not starting

Jump to solution

Hi Bob,

 

 

Before install the PPM 9.30 in your environment, did you ask for a license to the license team or your sales representative?

 

I mean, did you asked for the correspondent license prior make the upgrade?

If the answer is yes, I will need for a KSupport file please

And if the answer is that not yet you have requested for a license,  is necessary open a case with the License Team,  they will give you a new license.

 

 

Thanks

 

Best Regards,

Natalia Rojas

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Tags (1)
0 Likes
Frequent Contributor.. Bob_H Frequent Contributor..
Frequent Contributor..

Re: PPM 9.3 not starting

Jump to solution

I generated a license (we are an HP Platinum Partner and need this to demo sales opportunities), but I installed with the generated license and also using the temporary license that is available during install.  I get the same error for both.

0 Likes
Natalia_R_PPM Absent Member.
Absent Member.

Re: PPM 9.3 not starting

Jump to solution

Hi Bob,

 

Regarding the first error that you get:

Windows could not start the HP PPM <PPMname> service on <servername>.

Error 83: Fail on INT24.

 

I found the following:'

 

- Windows could not start the HP PPM <PPMname> service on <servername>.

 http://h30499.www3.hp.com/t5/Project-and-Portfolio-Management/Question-about-installing-HP-PPM-urgent/td-p/6063789#.VGo1pPnF-WA

 

"The first thing you should do is check the log files for the PPM server to see if it has started properly.  If you haven't changed any logging settings, the log should print out to the Cygwin window that you started PPM with.  If you have closed that Cygwin window, that may be part of the problem.  On Windows servers, you really need to use the services control panel to start and stop PPM.  If you start PPM in the Cygwin window, once you close the Cygwin window, all processes that it started are terminated, including PPM.  The installation should have created a service entry called 'HP PPM <servername>' that you can start and stop through the Services control panel"

 

Error 83: Fail on INT24.

http://www.error.info/windows/hardware-83.html

 

I suggest first try to kill all the java process and tasks, then perform the below steps in the machine with the issue   and let us know the results:

 

1) Stop the server.

2) Delete tmp and work and run kJSPCompiler.sh. Delete the two directories \server<\\tmp and \server\\work (file://tmp%20and%20/server/work)>

Note: Repeat for all servers (nodes)

Note: Do not back these directories up as they will be re-created when the PPM instance is started.

3) Go to PPM_HOME/server/SERVER_NAME/log and re-name the serverLog.txt file. This will allow for a clean log to review.

Note: Repeat for all servers (nodes)

4) Restart server

5) Run kRunCacheManager.sh -A (clear all cache).

 6) Clear ALL cache and history in Internet Explorer

If you have clustering, please repeat this for the entire nodes.

 7) Clear the Client Java cache.

Start --> Control Panel --> Java --> Temporary Internet Files --> Delete Files

 8) Also clear the client-side Java Virtual Machine(JVM) Cache. (Control Panel -> Java Plug-in -> Cache Tab -> 'Clear'). Do so for ALL Java Plug-ins installed.

 

 

Thanks

 

Regards,

Natalia R

 

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Frequent Contributor.. Bob_H Frequent Contributor..
Frequent Contributor..

Re: PPM 9.3 not starting

Jump to solution

Natalia,

 

    Thanks for the reply.  The first link did not really look to relate to my issue, and the second link I had already found and tried - it's saying that there is a hardware failure causing that error message, but I don't see it.

 

    I also followed your instructions and that did not help either, I still have the same problems.

 

    I am looking toward the license - it looks like for some reason it is not getting created:

 

Administrator@<servername> /cygdrive/c/PPM/bin
$ ./kLicenseReader.sh
Can not find the specified license file : conf/license.conf

 

   So I tried importing my License file and get this:

 

Administrator@<servername> /cygdrive/c/PPM/bin
$ ./kLicenseInstall.sh PPM_6542337.dat
JAVA_HOME = C:/Java/jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)
Installing the license key(s) from file...
0 license key(s) installed successfully

 

    And there is still no conf/license.conf file.  I think that is the root of my problem, and as I mentioned this happened with using the temporary license as well.  Any ideas?  THanks!

 

Bob

 

0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: PPM 9.3 not starting

Jump to solution

Hi Bob,

 

After checked your logs i can saw this " ERROR server:localhost-startStop-1:(Server.java:662):2014/11/17-11:19:44.211 EST: Administrator or Configuration License is not found."

 

In order to start PPM, you have to have foundation license, admin license and configuration license, so we can see that you don't have admin lincense and configuration license installed on you PPM and this is the root case make you cannot start PPM.

 

You should ask license team again to get correct license for PPM 9.30, if you just want an license for internal use, plese as them this license:

 

HP PPM 1 User for All Modules w/Portfolio Opt. 15-Month LTU for HP Internal

 

It work for me but im not sure it work for you or not, please try that.

 

 

Hope it helps.

 

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Frequent Contributor.. Bob_H Frequent Contributor..
Frequent Contributor..

Re: PPM 9.3 not starting

Jump to solution

Thanks, I will check that out and email HP licensing, but is your version 9.30?  It looks like they changed licensing from 9.2 to 9.3.  I only see one license available, "HP Project & Portfolio Manager Foundation 25+ Users SW E-LTU" which makes sense for what you say but I don't see any other licenses available, nor do the install instructions talk about importing any other licenses.

 

I'll email HP Licensing support though, thanks for the suggestion.  I'm open to anybody else's suggestions as well.

 

Bob

0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: PPM 9.3 not starting

Jump to solution

Hi Bob,

 

Yes, my version PPM  is PPM 9.30.  I also get the error like you, but after installed  the license like as i told in previous post i can start PPM 9.30 without problem. But it just a license for internal used.

 

 

Hope this helps.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: PPM 9.3 not starting

Jump to solution

Hi Bob,

 

I wonder my answer helped you ?

 

 

Thanks.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Frequent Contributor.. Bob_H Frequent Contributor..
Frequent Contributor..

Re: PPM 9.3 not starting

Jump to solution

Yes, thank you, I was able to get it going yesterday after working with HP and getting the correct licenses reissued.  I also wound up having to reinstall the application (it still didn't work after a simple license import) but since this was a single-core install and I had a VM snapshot of before I installed the Oracle DB, it only took about 45 minutes to do it.

 

Thanks for your help!

 

Bob

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.