Highlighted
Speedmaster Outstanding Contributor.
Outstanding Contributor.
1635 views

ALM 11.0, unable to checkout some QTP scripts ...

Jump to solution

We're running ALM 11.0 SP3. Also using UFT/QTP 12.0.

 

The automation team uses ALM to store  UFT/QTP scripts, and for version control. For some reason we noticed this morning that a handful of scripts could not be checked out. They can be pulled down into ALM, but the check-out option in UFT 12.0 is grayed-out (as is "Version History"). It's not all of the scripts, just a handful so far.

 

One developer found an old machine with QTP 11 on it and tried from there. He was able to check the script out from that machihne with the older version.

 

Has anyone here seen this behavior before? Any ideas as to what might be happening?

 

Thanks in advance,

Chris

0 Likes
1 Solution

Accepted Solutions
Absent Member.. Trudy Claspill Absent Member..
Absent Member..

Re: ALM 11.0, unable to checkout some QTP scripts ...

Jump to solution

According to this HP knowledge base article:

KM1389212 - What integration is available between other HP Products and QuickTest Pro (QTP) / Unified Functional Testing (UFT)?

 

To use UFT 12.00 with ALM/QC11.0 you must be on patch 16 or newer.  SP3 for ALM 11.0 was equivalent to patch 8. You need to start by loading patch 16 or newer on your ALM 11.0 server.

 

I don't know for a fact that will solve your problem, but working in an unsupported configuration could result in all kinds of weird behavior.

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
2 Replies
Absent Member.. Trudy Claspill Absent Member..
Absent Member..

Re: ALM 11.0, unable to checkout some QTP scripts ...

Jump to solution

According to this HP knowledge base article:

KM1389212 - What integration is available between other HP Products and QuickTest Pro (QTP) / Unified Functional Testing (UFT)?

 

To use UFT 12.00 with ALM/QC11.0 you must be on patch 16 or newer.  SP3 for ALM 11.0 was equivalent to patch 8. You need to start by loading patch 16 or newer on your ALM 11.0 server.

 

I don't know for a fact that will solve your problem, but working in an unsupported configuration could result in all kinds of weird behavior.

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Speedmaster Outstanding Contributor.
Outstanding Contributor.

Re: ALM 11.0, unable to checkout some QTP scripts ...

Jump to solution

Thanks, Trudy. I think that might be it.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.