Martin Sander Trusted Contributor.
Trusted Contributor.
384 views

ALM 11.52 : TestFolderFactory.AddItem - does it work ??

Hi Folks

 

ALM 11.52

 

Has anyone successfully managed to get the AddItem method to work in the Test Folder Factory ??

 

e.g.

Dim tdc As TDConnection
Dim obj_TestFolderFact As TestFolderFactory
Dim obj_TestFolder As TestFolder

'    Set tdc = New TDConnection

'           Create a Test Folder Factory
    Set obj_TestFolderFact = tdc.TestFolderFactory

'           Create the Folder
    Set obj_TestFolder = obj_TestFolderFact.AddItem(Null)

 

The guide states that SubjectNode object - the old way - has been deprecated and we should use the Test Folder Factory but I've not managed to get it to work ??


Throws an Automation error
Error Code : -2147221417
Error Description : Unexpected empty parameter

 

This seems to suggest that Null is not valid and that a number needs to be passed ?? If so where do I get the last number - remembering that Folders are held in ALL-LISTS

 

I can continue to use SubjectNode but would prefer to use the Test Folder Factory object

Any help greatly appreciated

 

Thanks

Martin

 

NOTE : The views expressed here are entirely my own

0 Likes
2 Replies
Absent Member.. Trudy Claspill Absent Member..
Absent Member..

Re: ALM 11.52 : TestFolderFactory.AddItem - does it work ??

After seeing your post I started experimenting with the TestFolderFactory and TestFolder objects through workflow code.  I didn't get any error on the AddItem line, but I still have not found a sequence of commands that actually creates a new folder that I can see in the UI.

 

I am also running ALM 11.52, with patch 5.

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
0 Likes
Highlighted
Martin Sander Trusted Contributor.
Trusted Contributor.

Re: ALM 11.52 : TestFolderFactory.AddItem - does it work ??

Hi Trudy

 

I have a solution using SubjectNode. Just would be nice to use the Test Folder Factory as defined

 

Also, all the code examples use SubjectNode - so note to HP that they need to update these

 

Thanks

Martin

 

NOTE : The views expressed here are entirely my own

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.