Highlighted
BDO Absent Member.
Absent Member.
438 views

HP ALM 11.0 - Bug_New function not executed when calling action StepsView.NewDefect

Hi,

 

I've inserted the code below in the Manual Runner Script Editor in order to trigger the "New Defect" window opening when a Test Step is set to "Failed".

 

Unfortunately, it seems that neither the Sub Bug_New nor Bug_MoveTo function is called, avoiding the customization code of those functions to be executed (to hide and auto fulfill fields). On the opposite, when I manually click on the "New Defect" button of the view, the Bug_New function is well executed and my fields are OK.

 

 

Sub Step_AfterPost
On Error Resume Next

If Step_Fields("ST_STATUS").Value = "Failed" Then
     Actions.Action("StepsView.NewDefect").Execute
End if

On Error GoTo 0
End Sub

 

 

 

Does anyone can explain this behavior ? Have you an idea of how I can investigate / debug ?

 

Regards

0 Likes
1 Reply
PSCSupport Super Contributor.
Super Contributor.

Re: HP ALM 11.0 - Bug_New function not executed when calling action StepsView.NewDefect

This is a known defect and you can review the Change Request if you have support access.

https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/KM01392611

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.