Highlighted
Absent Member.. sbrown_el Absent Member..
Absent Member..
885 views

HPE ALM Synchromnizer - link fails integrity check

I am trying to set up a Synchronizer link between QC12.21 and TFS2015 Update 2.1 and have run into a few problems.

First - the install doc indicates: "Navigate to C:\Program Files\Common Files\Microsoft Shared\Team Foundation
Server\14.0 on the machine where TFS 2015 is installed.".  and copy the files to a location on the Syncronizer server.  Unfortunately, a TFS server has next to nothing in this directory. and following the install instructions leads me to a non-functional ijnstall. Looking at the error messages produced, its  reasonable to believe that the files that Synchronizer seems to want are part of the Visual Studio installation (same path, but on a developer machine).  Using those files (Visual Studio 2015 Update 3). I was able to get Synchronizer to create a link between my QC and TFS servers.

Unfortunately - the link fails validation - on BOTH ends.   While the endpoint connectivity is present, there is something else at play, and the error messages are insufficient to determine what the issue is.

The integrity check indicates that the account (which is my QC admin account - I cant give it more privs than that) is missing "CREATE" priviledge. (On what, I dont know).

On the TFS side it fails in a "Fetching endpoint schema" step with the error : HPE ALM Synchronizer - Report

buildEntitySchema: disconnected Error converting value "System.Security.Principal.WindowsIdentity;---some-long-sid-----" to type 'Microsoft.VisualStudio.Services.Identity.IdentityDescriptor'. Path 'authenticatedUser.descriptor', line 1, position 167.

 It doesnt matter what domain account I give it, the error is the same (just a different SID mentioned in the error).

Any help would be appreciated.

0 Likes
4 Replies
Damodar-Reddy Acclaimed Contributor.
Acclaimed Contributor.

Re: HPE ALM Synchromnizer - link fails integrity check

Sbrown,

Before you create any Link.

you must be checking the connectivity between the tools.

Example:

1.User_TFS (Consider as user name)

2.User_ALM(Consider as user name)

Now, User_TFS should exist in ALM Site Admin with access to a project, in which you want to create a link.

User_ALM should exist in TFS & should have access to TFS Project.

& the URL of the ALM has to be Until "Http://xxxxx/qcbin" 

Check the connectivity first.

If all that works, then you can create the link, Field mapping & Integrity, Incremental & Full Synch..!!

(If this helped, accept as solution )
(Posts and opinions made here are my own and do not reflect the opinions of my employer)
0 Likes
Absent Member.. sbrown_el Absent Member..
Absent Member..

Re: HPE ALM Synchromnizer - link fails integrity check

Connection details validate to both sides (Syncronizer can log in to both sides) - Syncronizer wont let me create a link unless it can do this.

However the link does not validate properly. It fails the integrity check.

I have a support ticket open - HPE support has run through all the common config problems and we're working through the weirder ones now

0 Likes
Absent Member.. Tim_CO_OIT Absent Member..
Absent Member..

Re: HPE ALM Synchromnizer - link fails integrity check

I'm also quite interested in this issue, as it is occuring when I attempt to sync a vendor's TFS repository.

The crux of it, is that TFS is trying to cast/convert the Identity from a Windows directory service type (System.Security.Principal.WindowsIdentity) to a VisualStudio/TFS Identity type (Microsoft.VisualStudio.Services.Identity.IdentityDescriptor).  

I also question why the conversion is attempting:

System.Security.Principal.WindowsIdentity -> Microsoft.VisualStudio.Services.Identity.IdentityDescriptor

Instead of:

System.Security.Principal.WindowsIdentity -> Microsoft.VisualStudio.Services.Identity

But I've not looked up the documentation on those two objects on MSDN, to see if which, if either, can truly interchange.

It appears to be a common issue for those migrating to TFS 2015 and attempting to query work items ( even from MS Project and Excel, not just HPE ALM ).

See these other references to the same error:

https://social.msdn.microsoft.com/Forums/en-US/81cec4c1-a881-4e51-9222-fb45f6566aef/ms-project-not-able-to-read-queries-in-vsts?forum=project2010custprog

https://social.technet.microsoft.com/Forums/Windows/en-US/0f359ebe-bfaa-417c-ab93-2d47e0948860/project-pro-2016-fails-to-get-work-items-by-query-from-tfs-2015-update-2-error-converting-value?forum=projectprofessional2010general

 

0 Likes
HodaAb
Member.

Re: HPE ALM Synchromnizer - link fails integrity check

We had the same issue. The synchronizer installation guide mentions a step to copy files from the specified location (C:\Program Files\Common Files\Microsoft Shared\Team Foundation Server\14.0) to the adapters directory for HP Synchronizer. It seems this step is inaccurate as the necessary files are not present in the listed path. I downloaded the TFS2015.ZIP file from the link below: https://softwaresupport.softwaregrp.com/doc/KM02568091 and put the files in the path (C:\Program Files\HP\HP ALM Synchronizer\ adapters\net2015). Then I registered the "Register-TFS-Adapter.exe" file and restarted the synchronizer service. The problem solved this way.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.