Highlighted
chept Honored Contributor.
Honored Contributor.
114 views

Jira latest update 8.7 release, not supports ALM Synchronizer v15.00

Hi Team, 

We have new version of Jira updated in Atlassian and it is 8.7 and due that we are not able to open sync between ALM and jira.

As I check in below portal it says Jira of 8.4x only supported.

https://marketplace.microfocus.com/appdelivery/content/alm-synchronizer

Supported endpoints:

  • Atlassian Jira 8.2.x
  • Atlassian Jira 8.3.x
  • Atlassian Jira 8.4.x

And I get this error when I do create new link for end point of Jira, this link was working till December 2019.

ERROR #1- adapter.CONNECTION_FAILURE : Failed to connect to endpoint of type JIRA. Error: com.mercury.qc.gossip.exp.GossipServerException: adapter.CONNECTION_FAILURE : Failed to connect to endpoint of type JIRA. Error: com.hp.qc.synchronizer.adapters.exceptions.AdapterConnectionException: Failed to connect to project. Status code=403. Message=Forbidden..

ERROR #2- adapter.CONNECTION_FAILURE : Failed to connect to endpoint of type JIRA. Error: com.hp.qc.synchronizer.adapters.exceptions.AdapterConnectionException: Failed to connect to project. Status code=403. Message=Forbidden.

ERROR #3- Failed to connect to project. Status code=403. Message=Forbidden

Best Regards,

Chethan

Thank you...
0 Likes
4 Replies
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Jira latest update 8.7 release, not supports ALM Synchronizer v15.00

Support for the latest Jira versions will come with our next release of the ALM Synchronizer which should be out in about 2 months from now. 

I can say that the error you provided seems to be related to an authentication problem and not from product incompatibility so I suggest you check that path. 

 

chept Honored Contributor.
Honored Contributor.

Re: Jira latest update 8.7 release, not supports ALM Synchronizer v15.00

Thanks for response,

After updating user permission i get below error now.

 

 ERROR #1- adapter.CONNECTION_FAILURE : Failed to connect to endpoint of type JIRA. Error: com.mercury.qc.gossip.exp.GossipServerException: server.RemoteExecService.UNHANDLED_EXCEPTION : Unknown exception type is caught: com.hp.qc.synchronizer.adapters.exceptions.AdapterException: Unable to retrieve user permissions...
ERROR #2- server.RemoteExecService.UNHANDLED_EXCEPTION : Unknown exception type is caught: com.hp.qc.synchronizer.adapters.exceptions.AdapterException: Unable to retrieve user permissions..
ERROR #3- Unable to retrieve user permissions.
ERROR #4- Failed : HTTP error code : 400 'null' with message: {"errorMessages":["The 'permissions' query parameter is required."],"errors":{}}

Thank you...
0 Likes
chept Honored Contributor.
Honored Contributor.

Re: Jira latest update 8.7 release, not supports ALM Synchronizer v15.00

@Udi Weinberg Could you pls look into new error. 

Thank you...
0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Jira latest update 8.7 release, not supports ALM Synchronizer v15.00

Please submit a support ticket if the issue is urgent and you cannot wait for the new release. Thanks!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.