Highlighted
Absent Member.
Absent Member.
2732 views

Need help on executing scripts via ALM

Jump to solution

I tried to execute scripts on another machine(Windows XP SP3) from my computer(Win7) from ALM.

the trial version of UFT is 11.5 and ALM is 11, the firewall turned off

there is no domain and scripts can be executed locally

but each time I executed scripts on another machine from ALM

it ended up popping up a window and saying "You do not have permissions to run tests on this machine. You can change this option in your testing tool's Options dialog box."

actually I already set the option to allow other HP products to run tests and components on that machine.

 

is anybody out there who knows how to work it out?

 

0 Likes
1 Solution

Accepted Solutions
Honored Contributor.
Honored Contributor.

Re: Need help on executing scripts via ALM

Jump to solution
what patch of ALM ?
we got response few days from HP like this,

UFT 11.5x/12 does not support the older versions of PC (support for PC 11.51 and above). It does support QC/ALM 11 Patch 15 and above.
Thank you...

View solution in original post

0 Likes
11 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Need help on executing scripts via ALM

Jump to solution
Regarding the Windows XP system, is there a user with administrator permission already logged on to that machine before you begin the script execution through ALM?

And the user credentials you are using to connect to your Win 7 system - do those credentials have administrator permissions on the Windows XP system?
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Need help on executing scripts via ALM

Jump to solution

Hi iamcodylee,

 

Please go to UFT -> Tool -> GUI Testing -> Test runs, make sure that you checked "Allow other HP products to run tests and component".

After that, try to run script again via ALM

 

Regards,

"HP Support
If you find this or or any post resolves your issue, please be sure to mark it as an accepted solution and give KUDOS to the author for their assistance."
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Need help on executing scripts via ALM

Jump to solution
I logged on to Win7 as administrator and btw UAC has turned off,
at the same time, the user that logged on to Win XP is still administrator.
the difference is that I use different acct to log on to Win7 and XP, would that be a problem?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Need help on executing scripts via ALM

Jump to solution
Oh, already checked that option,
thanks.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Need help on executing scripts via ALM

Jump to solution
Try this.

On your Win XP system add the user account you use on your Win 7 system and grant it admin privileges.

You shouldn't have to be logged in to both systems as the same user, but the user connected to the Win 7 system may need permissions to access the Win XP system.
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Need help on executing scripts via ALM

Jump to solution
Yes, I already created the same user account as I log into in Windows XP and grant it admin privileges.
at the same time, in DCOM settings in Windows XP, I also assign Local launch, Remote launch, Local activation and Remote activation to the acct as same as it in Win7
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Need help on executing scripts via ALM

Jump to solution
Another question to ask,
the 135 port on the client computer is currently on(Windows XP uses this port as service called RPC)
would it be possible that makes me unable to execute BPT scripts from another computer via ALM?
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Need help on executing scripts via ALM

Jump to solution

Can you try launching the QC  as admin in local machine ?

 

Also when you start the test what is happening Destination machine ? is it launching QTP ?

Thank you...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Need help on executing scripts via ALM

Jump to solution
I have not installed QC in local machine...

No....a resounding NO...........
Nothing happened to the destination machine when start the test, QTP didn't launch.
0 Likes
Honored Contributor.
Honored Contributor.

Re: Need help on executing scripts via ALM

Jump to solution
what patch of ALM ?
we got response few days from HP like this,

UFT 11.5x/12 does not support the older versions of PC (support for PC 11.51 and above). It does support QC/ALM 11 Patch 15 and above.
Thank you...

View solution in original post

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Need help on executing scripts via ALM

Jump to solution
patch 12....
from your information, I think i should upgrade my ALM
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.