Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Highlighted
Planet Earth Absent Member.
Absent Member.
1405 views

QC defect email fucntionality not working

For some reason, we stopped getting auto generated emails in the QC defect module for all projects. We need to manually select the SEND EMAIL NOW button from Site Admin to have all emails be generated.
This was working before.
Has anyone had the same problem? How was it resolved?
Thanks.
0 Likes
13 Replies
SreeKrishnan Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

1. Did you check to see if the Send mail automatically is selected fr each project in your Site Admin Site projects tab (right side of the screen).

2.Set the MAIL_INTERVAL to anything greater than 10 (10 or more) on the Site Config tab in Site admin

3. Did you try the Send-Email Now button on the Site Projects tab for the project.

4. You can also use the IP address of the Mail server on the MAIL_SERVER_HOST instead of the Server name in the Site Config tab

0 Likes
Rhonda Robinson Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

Have you had any type of service interuption such as a power outage or a restart of the mail or QC server? In our experience, these events cause QC adn the mail server to quit talking. Yes the manual mail and the Send Now both function as expected, but the auto notification piece is no longer in sync.

We have corrected the issue by simply restarting the QC service (once we are assured the mail service is running properly).
0 Likes
Planet Earth Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

Thanks for the prompt reply....answers to your questions.

1. Yes it is selected.

2. Is there a reason why the MAIL_INTERVAL should be set to to anything greater than 10 (10 or more)? I was under the impression that this should be less that 10.

3. Yes. That is the only way that defect emails can be generated. For some reaosn it cues it up.

4. I'll try use the IP instead of the Server name
0 Likes
SreeKrishnan Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

As Rhonda suggested a restart of the QC service can help.
0 Likes
Planet Earth Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

I will try that too.

Thanks!
0 Likes
Rhonda Robinson Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

If the Mail Interval is set too low and there are a lot of qualified items to send, there is a possibility of over loading the mail queue. Also, if all of the currently qualified items have not yet been successfully sent when it becomes time to send mail again, some of the messages may not get sent. The 10 min threshold was determined by users with a large number of projects and users to be the bottom level for ensuring that no problems are encountered.
0 Likes
Planet Earth Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

Thanks for all the help!
0 Likes
Vladimir Skrbek Acclaimed Contributor.
Acclaimed Contributor.

Re: QC defect email fucntionality not working

Just information about the mail interval.

We have to set up it to 25. When we set it to 10 minutes the mails were stoped working in some time about after 6 months without reason. Then we restart the server and it does not help. Then we set this interval to higher number (to 15) and restart the server and it begins to work. After some time it again stopped work so we again set the interval to higher number and so on. Right now we are on the 25 minutes. :-)
0 Likes
teamplayer2008 Absent Member.
Absent Member.

Re: QC defect email fucntionality not working

Many people on this thread seem to be very knowledgable about QC email service.

I'm still trying to get the manual QC e-mail service working before I proceed to automatic QC e-mail notification working.

I've made a few changes to VirusScan and Default SMTP Virtual Server to send e-mail from QC 9.2.

I nevigate to Defect Detail->Send by E-Mail to bring up the Send E-mail window, then I can send out e-mail there with valid e-mail addresses. When the mail is sent, there is a little pop-up confirmation window with message as "Mail sent successfully".

However, the mail is not actually received at the destination mail account.

I use a hotmail account to send the mail and a gmail account to receive it. Of course I own both of these two email accounts and have verified that I can exchange mails between these two mail accounts.

Can someone help me please?

Thanks in advance.
0 Likes
Contributor.. Rsinquin Contributor..
Contributor..

Re: QC defect email fucntionality not working

Exactly the same problème,

Except it work for some project and not for another.

 

I up MAIL_INTERNAL from 10 to 15 and no changes.

Does Microfocus have à real and validated corrective action ?

 

0 Likes
Honored Contributor.. arichtman Honored Contributor..
Honored Contributor..

Re: QC defect email fucntionality not working


@Rsinquin This thread is 10 years old...

0 Likes
Contributor.. Rsinquin Contributor..
Contributor..

Re: QC defect email fucntionality not working

ok but in QC/ALM 12.55 the problem still existe.

And your solve tree don't work.

0 Likes
Contributor.. Rsinquin Contributor..
Contributor..

Re: QC defect email fucntionality not working

Solved by : Remove project (not delete)/ supp project ID in xml / restore project

 

A noter pour Microfocus la cause probable est qu’importer un projet exporter du même serveur bloque notifiant que l’index existe déjà et en profite pour casser les index… la sécurisation est mal faite.

Notice that the it might be due to the import process that destroy index before notice import impossible with a export from the same serveur.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.