Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Steven Hulse Absent Member.
Absent Member.
224 views

QC v10 defect numbers jumping

Jump to solution

Good day everyone,

 

We've noticed something odd in QC v10 (patch 17) where suddenly the defect ID numbers will jump. For example, the last defect entered was ID #32 and then a few days later it will start with #100 with nothing in betweeen.

 

No data has been lost but I was wondering if anyone else has seen or experienced this or knows what causes this?

 

Thanks

Steve

0 Likes
1 Solution

Accepted Solutions
Highlighted
Steven Hulse Absent Member.
Absent Member.

Re: QC v10 defect numbers jumping

Jump to solution

Hi Rhonda,

 

Thanks for the reply! Apparently this was a known issue and is addressed in Patch 19 for QC v10. I'll be applying patch 20 this afternoon (Friday January 21st, 2011) so hopefully that will resolve our issue.

 

Defect ID: QCCR1J14790
Problem: Defect ID numbers randomly increase by increments of 100, or IDs are not added in sequential order when Quality Center is deployed on a cluster.
Solution: The problem is fixed.
Limitation: In legacy projects, the problem may recur just after restart.

 

To answer your questions, as far as we know or can tell in the log files, no one has deleted items or ran the SQL you mentioned. As for any custom code, we only have one project that has that and we went through it and couldn't find anything. After we applied patch 17 we've noticed this issue along with an issue with the comments field. However I can't say that the cause was patch 17.

 

Steve

0 Likes
2 Replies
Rhonda Absent Member.
Absent Member.

Re: QC v10 defect numbers jumping

Jump to solution

The Defect ID is a sequential number retrieved from the Sequences table.  This table holds what should be the NEXT value for an entered defect.

 

If defects have been entered and deleted, those numbers appear to be skipped as they were previously used and the Sequences table value continued to increment.  Has anyone deleted defects?

 

There is a SQL query which can be run to update the Sequences table.  Has anyone intentionally (or unintentionally) executed such a query?

 

Is there any custom code within your workflow script which may be updating the Sequences table?

0 Likes
Highlighted
Steven Hulse Absent Member.
Absent Member.

Re: QC v10 defect numbers jumping

Jump to solution

Hi Rhonda,

 

Thanks for the reply! Apparently this was a known issue and is addressed in Patch 19 for QC v10. I'll be applying patch 20 this afternoon (Friday January 21st, 2011) so hopefully that will resolve our issue.

 

Defect ID: QCCR1J14790
Problem: Defect ID numbers randomly increase by increments of 100, or IDs are not added in sequential order when Quality Center is deployed on a cluster.
Solution: The problem is fixed.
Limitation: In legacy projects, the problem may recur just after restart.

 

To answer your questions, as far as we know or can tell in the log files, no one has deleted items or ran the SQL you mentioned. As for any custom code, we only have one project that has that and we went through it and couldn't find anything. After we applied patch 17 we've noticed this issue along with an issue with the comments field. However I can't say that the cause was patch 17.

 

Steve

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.