Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Respected Contributor.. Pauld Respected Contributor..
Respected Contributor..
334 views

Server is muted due to unrecoverable error

Jump to solution

Hi,

I have installed ALM 12.60 on an AWS EC2 intsance. When I try to open ALM on a browser I get the error message

Server on 'XXXXXXXXXXXX' has entered an unstable state, please contact your site administrator.status=MUTED, label=QC server is muted due to unrecoverable error, reason=The parameter name COMMUNICATION_SECURITY_PASSPHRASE does not exists in PARAMS table.

This install was to connect to a current schema on a SQL server. The install did not ask me for a communication secruity passphrase. (It did ask me for the passphrase when I installed 12.60 on a diferent EC2 instance that was creating a new schema).

I have checked the qcConfigFile.properties file and it does contain a passphrase. As you would expect though this is encrypted.

 

communicationSecurityPassphrase=QCC:xJIkXjTDIlSXOYp60rL4L9cHa9jaQ/N2ufeOYZwafPuUB4zOQTlSJ/0G4tHECoy0DsWuyvTsRC/vBDPwSCRk+ptUF6SI/bI/7HJM1ehyI0GCvrjQbGFJ5dHZeUhROk1hptiHHh2/dhisyPuWcfNXnFOCXTOM+55U9rSZ4BGMPxVjGFTblzouMA0mt3LaAnvy

Does anyone have a solution to this?

Thanks

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Server is muted due to unrecoverable error

Jump to solution

Hello,

Are you trying to add a second ALM node? like cluster?

If yes, as the issue seems to be related to the COMMUNICATION_SECURITY_PASSPHRASE you can try stopping the ALM service on the second node, copy the siteadmin.xml file from the primary node, then restart ALM on the second node. 

On node 2 only:
stop the "ALM" process:

Copy the siteadmin.xml file from node 1 to node 2 in two places.
The default file locations are:
\webapps\qcbin\WEB-INF\siteadmin.xml
\application\20qcbin.war\WEB-INF\siteadmin.xml

start the ALM process again

 

If it is not a second node, you need to start to check if the COMMUNICATION_SECURITY_PASSPHRASE that is under the PARAMS table in qcsiteadmin_db match with the communicationSecurityPassphrase under qcConfigFile.properties that you checked and that was used for the installation.

1 Reply
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Server is muted due to unrecoverable error

Jump to solution

Hello,

Are you trying to add a second ALM node? like cluster?

If yes, as the issue seems to be related to the COMMUNICATION_SECURITY_PASSPHRASE you can try stopping the ALM service on the second node, copy the siteadmin.xml file from the primary node, then restart ALM on the second node. 

On node 2 only:
stop the "ALM" process:

Copy the siteadmin.xml file from node 1 to node 2 in two places.
The default file locations are:
\webapps\qcbin\WEB-INF\siteadmin.xml
\application\20qcbin.war\WEB-INF\siteadmin.xml

start the ALM process again

 

If it is not a second node, you need to start to check if the COMMUNICATION_SECURITY_PASSPHRASE that is under the PARAMS table in qcsiteadmin_db match with the communicationSecurityPassphrase under qcConfigFile.properties that you checked and that was used for the installation.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.