Absent Member.. Jim Bradee Absent Member..
Absent Member..
8246 views

object reference not set to an instance of object when creating a defect while executing a test case

Jump to solution

Only some of my users are receiving an error, Object reference not set to an instance of object.  This only occurs while creating a defect while manually executing a test case in test lab.   We have already tried uninstalling the client.  It seems to be unique to the machine running HPALM, not the user.   Any suggestions would be helpful.

 My ALM configuration is below:

Internal Components                                Build

Site Administration Client                         12.50.1479.0
WebGate Client                                     12.50.1479.0
Application Lifecycle Intelligence 2.9             12.50.154582
Sprinter                                           12.50.1479
Quality Center                                     12.50.1479
Analysis Extension                                 12.50.1479
ALM Lab Extension for functional and performance testing 12.50.1479
ALM Lab Management Extension                       12.50.1479
ALM Dev Extension                                  12.50.1479
Enterprise Integration for SAP applications        12.50.1709
Application Model                                  12.50.0

Quality Center
Site Administration 12.50.59 (Patch 1)

0 Likes
1 Solution

Accepted Solutions
Absent Member.. Jim Bradee Absent Member..
Absent Member..

Re: object reference not set to an instance of object when creating a defect while executing a test

Jump to solution

Your response gave me a start on what to look for and we noticed that an entire group of test cases were mapped incorrectly when they were imported, and did have blank step names.  We corrected that and the error is no longer occuring. 


 


@Roy_C_QC wrote:

Hello Jim,

Thanks for submitting this request,

Regarding the described error it seems it has been recently reported. For this reason check the details below:

 

Previously this type of error has been related to a blank step name.

To resolve it:

- Let's backup the project DB

- Navigate to the project -> DESSTEPS table.

- Run sql statement : update DESSTEPS set DS_STEP_NAME = 'step_' + convert(varchar, DS_STEP_ORDER) WHERE DS_STEP_NAME IS NULL

 

Please try these steps, and kindly let me know if the issue persist.

Your comments will be appreciated,

Thank you,

Greetings,




0 Likes
8 Replies
Roy_C_QC Honored Contributor.
Honored Contributor.

Re: object reference not set to an instance of object when creating a defect while executing a test

Jump to solution

Hello Jim,

Thanks for submitting this request,

Regarding the described error it seems it has been recently reported. For this reason check the details below:

 

Previously this type of error has been related to a blank step name.

To resolve it:

- Let's backup the project DB

- Navigate to the project -> DESSTEPS table.

- Run sql statement : update DESSTEPS set DS_STEP_NAME = 'step_' + convert(varchar, DS_STEP_ORDER) WHERE DS_STEP_NAME IS NULL

 

Please try these steps, and kindly let me know if the issue persist.

Your comments will be appreciated,

Thank you,

Greetings,

Roy Chinchilla Ramírez
Software Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the option at the bottom left of the post and show your appreciation.
0 Likes
Damodar-Reddy Acclaimed Contributor.
Acclaimed Contributor.

Re: object reference not set to an instance of object when creating a defect while executing a test

Jump to solution

Is that QC Instance in the IE opened in a same window in multiple tabs, meaning 2 QC Instances in a single IE window?

If or if not above, Re-register the QC Client, from Tools-->Addins-->Register HP ALM.

clear the IE Cache & remove td_80 folder from temp.

& Launch again to see. this error is not particular for one view, 

(If this helped, accept as solution )
(Posts and opinions made here are my own and do not reflect the opinions of my employer)
0 Likes
Absent Member.. Jim Bradee Absent Member..
Absent Member..

Re: object reference not set to an instance of object when creating a defect while executing a test

Jump to solution

Your response gave me a start on what to look for and we noticed that an entire group of test cases were mapped incorrectly when they were imported, and did have blank step names.  We corrected that and the error is no longer occuring. 


 


@Roy_C_QC wrote:

Hello Jim,

Thanks for submitting this request,

Regarding the described error it seems it has been recently reported. For this reason check the details below:

 

Previously this type of error has been related to a blank step name.

To resolve it:

- Let's backup the project DB

- Navigate to the project -> DESSTEPS table.

- Run sql statement : update DESSTEPS set DS_STEP_NAME = 'step_' + convert(varchar, DS_STEP_ORDER) WHERE DS_STEP_NAME IS NULL

 

Please try these steps, and kindly let me know if the issue persist.

Your comments will be appreciated,

Thank you,

Greetings,




0 Likes
Roy_C_QC Honored Contributor.
Honored Contributor.

Re: object reference not set to an instance of object when creating a defect while executing a test

Jump to solution

Hi again Jim,

I am very glad to hear that the error is no longer occuring!

Please consider me at your disposal if any further assistance is required. I will be more than glad to assist you,

Have a nice day,

Thanks,

Kind regards,

Roy Chinchilla Ramírez
Software Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the option at the bottom left of the post and show your appreciation.
0 Likes
Respected Contributor.. Sohel Respected Contributor..
Respected Contributor..

Re: object reference not set to an instance of object when creating a defect while executing a test

Jump to solution

Hello there,

I am trying to get a similar solution for the Null Reference error. In our case for a project (ALM 12.53) we uploaded many test cases using Excel Add In. For a large number of these test cases the "Type" field was not filled as "Manual" and for rest the "Type" fields were filled as "Manual". For test cases that does not have "Type" field filled we are getting Null Reference error while trying to raise a defect from a failed step. Please kindly let me know how to resolve this, if possible using ALM OTA (VB or C#). 

The SQL code that you have that is for correcting the Test Step blank issue per the original requestor's question. How can I modify it to apply it for Type field for eachTest steps and for all test cases?

 Thank you.

0 Likes
Kalki Respected Contributor.
Respected Contributor.

Re: object reference not set to an instance of object

Jump to solution

I am using loadRunner 12.53.

I run a Scenario of RDP scripts, when it is completed, I find I am not able to retrieve raw data reports from Analysis software as it throws the following error,

The error is "Object Reference is not set to an instance of object". 

Kindly help.

Thanks in advance.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: object reference not set to an instance of object

Jump to solution

Hello,

Sorry, I have not seen this error in LoadRunner before.

This is the ALM Practitioner forum. Maybe you will get better replies when you post your question in the LoadRunner / Performance Center practitioner forum. Here is the direct link for you:

https://community.saas.hpe.com/t5/LoadRunner-Performance-Center/ct-p/sws-LoadRunner

Regards,

-Thomas

0 Likes

Re: object reference not set to an instance of object when creating a defect while executing a test

Jump to solution

Hello,

When i am trying to access the 'Parameters' tab in Test Plan module for any test scripts which are created with BPT framework for automation, getting this error "System.NullReferenceException: Object reference not set to an instance of an object."

Can anyone help on this? 

Note: This issue is occurring only after DB migration (which was accessible prior to that)

 

Regrads,

Harsha

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.