Highlighted
Larry Weisberg
Visitor.
77 views

RumbaDevelopersEditionVisualStudioAddIn for VS 2017/2019

I am trying to install RumbaDevelopersEditionVisualStudioAddIn and have it usable from my VS 2019 (or even 2017).  When I run the following (recommended in the support pages):

  • msiexec /i RumbaDevelopersEditionVisualStudioAddIn.msi ADDLOCAL=RumbaDE_VSD_2017_Professional 

I get the error: Microsoft Visual Studio 2012 or 2013 or 2015 must be installed before installing Micro Focus Rumba 9.5 Developers Edition Visual Studio Package.

Anyone have any ideas?

0 Likes
4 Replies
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: RumbaDevelopersEditionVisualStudioAddIn for VS 2017/2019

Larry,

The documentation you are referring to specifically mentions RumbaDE_VSD_2012
RumbaDE_VSD_2013
RumbaDE_VSD_2015
I believe only these versions of Visual Studio are expected by the installer. The documentation does not specifically state what versions of VS are compatible, but this is probably your issue.

Thanks,
Jeff
0 Likes
Larry Weisberg
Visitor.

Re: RumbaDevelopersEditionVisualStudioAddIn for VS 2017/2019

Looking at the information here: 

https://www.microfocus.com/documentation/rumba/desktop951/RumbaSystemAdminGuide/GUID-81AE7BAB-749B-4610-AB1B-7BE8678F9117.html ,

I also see:

  • RumbaDE_VSD_2017_Community
  • RumbaDE_VSD_2017_Enterprise
  • RumbaDE_VSD_2017_Professional
0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: RumbaDevelopersEditionVisualStudioAddIn for VS 2017/2019

Thanks Larry.  What about the version of .NET framework?  There is a note in the documentation that the add-in requires .NET 4.7.1 but 4.6.1 installs by default with 2017.  It would make this an inaccurate message, but might be something to check.  If this doesn't help, you can contact our Customer Care team at 800-632-6265 for assistance with this issue.

Thanks,

Jeff

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RumbaDevelopersEditionVisualStudioAddIn for VS 2017/2019

Hi Larry,
to use the  RumbaDeveloperEdtion Addin with VS2017 you need a  SP1 Hotfix.( SP1_HF_18323 or later).
As suggested by Jeff please contact the supportline.

clipboard_image_0.jpeg

cheers

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.