Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
curtiplas Frequent Contributor.
Frequent Contributor.
9576 views

Modify OEGatewayService URL

Jump to solution
Does anyone know how to modify the URL of the OEGatewayService. I'm getting an invalid request handle, I suspect this is because the request to the URL is failing as it's trying to hit https over port 80.

Note: I'm using IIS to proxy all tomcat traffic & I've already modified the environment targets to reflect this change.

Below is the error I'm getting in the orchestration I'm working on:

Error occurred during web service invocation: 

RequestPost
Connection handle is OK
Unsafe SSL is not allowed
Calling SendRequest
Client certificate doesn't needed
Calling SendRequest
Client certificate doesn't needed
error Invalid request handle

Response failed...
Couldnt connect to https://dev.support.mdtsaas.com:80/OEGatewayService/oegs?ns=00000&mt=SubmitAuxDataEventNoticeWithReply&mn=&pn=Submit_Aux_Data&id=3c1c8ce6-6530-4a0f-9515-10a5fc5a2632
0 Likes
1 Solution

Accepted Solutions
curtiplas Frequent Contributor.
Frequent Contributor.

Re: Modify OEGatewayService URL

Jump to solution
No, there are two options, the one I use actually allows all tomcat traffic to traverse through IIS; the other allows you to utilize your own proxy.

Also looks like my issue was resolved, after modifying this setting and modifying targets and endpoints, I also apparently need to redeploy the Global Process app, then my process app with the orchestration to ensure that the Orchestration Environment url is updated correctly. Everything is now traversing over 443 🙂
0 Likes
4 Replies
PM Thompson Acclaimed Contributor.
Acclaimed Contributor.

Re: Modify OEGatewayService URL

Jump to solution
First suggestion: try Serena Support (David Goodale)

  • What version of SBM?
  • Do you have different servers for AE and OE?
  • You said you're using IIS to proxy incoming requests. How?
  • Won't there be a conflict if you're sending OE traffic to the same server & port or ports used by the AE? That's why OE is usually on 8243 unless it's on a dedicates server.
  • You probably want to redact your server name, especially if it's internet-facing.
Just guessing on my part: Configurator / Security tab / Secure SSO / SSO URL Overrides
0 Likes
curtiplas Frequent Contributor.
Frequent Contributor.

Re: Modify OEGatewayService URL

Jump to solution
Paul Thompson wrote:

First suggestion: try Serena Support (David Goodale)

  • What version of SBM?
  • Do you have different servers for AE and OE?
  • You said you're using IIS to proxy incoming requests. How?
  • Won't there be a conflict if you're sending OE traffic to the same server & port or ports used by the AE? That's why OE is usually on 8243 unless it's on a dedicates server.
  • You probably want to redact your server name, especially if it's internet-facing.
Just guessing on my part: Configurator / Security tab / Secure SSO / SSO URL Overrides



Thanks Paul, I have a support case open I'm waiting to hear back on still, but to answer your questions:


  • SBM 11.1
  • All components except the DB are on a single server (AE & OE).
  • I'm using the setting in configurator to proxy all requests through IIS (Configurator>Component Servers>Use IIS to proxy all server requests).
  • It's an internal only dev server, so i'm not terribly concerned.
0 Likes
PM Thompson Acclaimed Contributor.
Acclaimed Contributor.

Re: Modify OEGatewayService URL

Jump to solution
I thought that the proxy settings in SBM Configurator didn't provide a proxy -- they just enable SBM to be used with an external proxy service that would need to be configured.
0 Likes
curtiplas Frequent Contributor.
Frequent Contributor.

Re: Modify OEGatewayService URL

Jump to solution
No, there are two options, the one I use actually allows all tomcat traffic to traverse through IIS; the other allows you to utilize your own proxy.

Also looks like my issue was resolved, after modifying this setting and modifying targets and endpoints, I also apparently need to redeploy the Global Process app, then my process app with the orchestration to ensure that the Orchestration Environment url is updated correctly. Everything is now traversing over 443 🙂
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.