Commodore Commodore
Commodore
1344 views

IDM stays at 0/2 after upgrading CDF to 2019.02 (readiness probe fail)

Hello,

After upgrading the CDF to version 2019.02,  when checking kube-status   it seems idm deployment is not being up.   

from kube-status output:

Ekran AlıntısidmIDM.JPG

 

kubectl get deployments -n core    :  

idm 0/2 

 

kubectl get pods -n core:

Ekran AlıntısıNcore.JPG

kubectl describe pod idm-597756fd98-5bksp -n core :

...

..

Warning ....  .....               Readiness probe failed: HTTP probe failed with statuscode: 404

 

I can not login to both cdf administration and suite pages.

 

Any idea please?  

Thanks. 

Levent.

 

 

 

 

0 Likes
17 Replies
Commander Commander
Commander

Hi,

I have the same issue.
Have you already solved it?

Commodore Commodore
Commodore

Same issue here!

There should be a publishing solution from R&D. Back in June we had the issue in one of our environments and we worked out a workaround with the following command:

kubectl exec -ti -n core idm-757cb77cd6-km64c -c idm sh

 Then disabling SSL inside the pod.

We do not have the history of commands inside the pod. 

 

Can someone help please?

 

0 Likes
Micro Focus Expert
Micro Focus Expert

I suggest opening a ticket.

0 Likes
Commodore Commodore
Commodore

As a workaround you can disable ssl for postgres:

 

kubectl edit cm default-database-configmap -n core

 

And change DB_SSL_ENABLED from "true" to "false"

 DB_SSL_ENABLED: "false"


And restart the idm deployment.

kubectl scale --replicas=0 deployment idm -n core

kubectl scale --replicas=2 deployment idm -n core

0 Likes
Commodore Commodore
Commodore

As a workaround you can disable ssl for postgres:


kubectl edit cm default-database-configmap -n core


And change DB_SSL_ENABLED from "true" to "false"

DB_SSL_ENABLED: "false"


And restart the idm deployment.

kubectl scale --replicas=0 deployment idm -n core

kubectl scale --replicas=2 deployment idm -n core

0 Likes
Micro Focus Expert
Micro Focus Expert

Hello , 

Please get into the IDM container and run the following command.
find /  com.microfocus.cdf_2019.02_Update_admin_User.json

If the file exists, rename it to com.microfocus.cdf_2019.02__Update__admin__User.json and restart the pod. 

The naming convention should be like this __Update__admin__User.json . I had faced similar issue where my idm pods were 1/2 and renaming file helped me from _ to __

Please do try this once , hope it helps 

 

Regards

Praveen 

 

Regards

Praveen 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.