Commodore
Commodore
1208 views

DKIM troubleshooting

Jump to solution

Hello there,

I configured DKIM signing in the SMG/SLES appliance. Generated keys in Domain Management. Public key added in DNS. Checked record with online tool -> OK.

Then send a message and checked it with https://www.appmaildev.com/en/dkim. Result: DKIM none. Double-checked with gmail on the security button: no encryption.

How can I check in the logs what goes wrong?

I see in the supervisor log this:

[139824307939072] 2020-04-09 19:58:35 (DBCB) DB notification: dkimupdate
[139824341509888] 2020-04-09 19:58:35 (dkim) Processing DKIM signature updates start
[139824341509888] 2020-04-09 19:58:35 (dkim) Add/update DKIM record for d=meerdaneen.nl, s=20200409
[139824341509888] 2020-04-09 19:58:35 (dkim) Processing DKIM signature updates complete

Anyone?

 

 

 

 

0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

SMG offers two parts to DKIM:

1) DKIM signing -  https://www.novell.com/documentation/secure-messaging-gateway/secure-messaging-gateway/data/t44kudeqbeaz.html

2) DKIM verification - https://www.novell.com/documentation/secure-messaging-gateway/secure-messaging-gateway/data/t4462m6nhr4z.html 

This release fixed the DKIM signature, that wasn't being attached. If that is the part that still isn't working for you I would recommend opening a ticket with support.

View solution in original post

0 Likes
19 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Did you see this discussion? https://community.microfocus.com/t5/SMG-User-Discussions/Warning-after-SLES-upgrade-DKIM-not-working/td-p/2758842

Diethmar Rimser
This community is more powerful if you use Likes and Solutions
Knowledge Partner Knowledge Partner
Knowledge Partner
Did not mean to double up on you. 🙂
--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums!
Don't forget to Like helpful posts and mark Solutions!
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

DKIM in the SLES based SMG appliance is currently broken.  There are some other threads about it on the forums.  Supposedly it is being worked on now, but I have no idea when the fix will be released.  Hopefully soon as I am a bit frustrated by this.

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums!
Don't forget to Like helpful posts and mark Solutions!
Commodore
Commodore

Just posted a SR. Let's put the pressure on the dev's!

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

The more the merrier.  🙂

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums!
Don't forget to Like helpful posts and mark Solutions!
0 Likes
Micro Focus Expert
Micro Focus Expert

Hi Jan,

I think I just replied to your support ticket. I thought I'd post this for others to see the news as well.

The developers are currently working on this. It had been pushed back due to higher priority issues that came up, but they now have time to work on it. Hopefully we will have a fix soon. I'm sorry this is taking so long to get a fix out.
Thanks for your patience.

Suzie

 

0 Likes
Commodore
Commodore

Thanks Suzie for your reply,

Hope we will get is soon indeed. When I hear from others that they are already waiting for this for months, excuse me for saying it, it is about time.  We are not talking about new features, but we are talking about features that are already sold with the product, but never delivered.

So can we expect something in the next, let's say 2-3 weeks?

 

 

0 Likes
Micro Focus Expert
Micro Focus Expert

I agree, it is frustrating when a bug takes so long to get fixed. I do know they are actively working on it, and we are doing some testing with it today. Unless, some unforeseen issue with the fix comes up then yes I would expect it to be out within 2-3 weeks, if not sooner.

Sorry again, that this has taken so long.

Commodore
Commodore

Thx Suzie! You made my day 😉

0 Likes
Commodore
Commodore

Hello Suziew and others,

 

Today revision 95 was released, as an upgrade from 88. Excited as I was to see that DKIM problably would work, and disappointed now that it still does not work. There is no DKIM encryption added to the email.

Is that correct? So will we get another update in the next days with DKIM working, as promised?

Another question: it is great if DKIM works. But how about checking of DKIM. Is SMG capable of checking DKIM? I guess it should be on the SMTP interface somewhere. But I cannot find it. Any plans of implementing it?

 

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

I received an FTF about a week ago and applied it and DKIM is working.  It did require a create/regenerate of the keys.  In my case I ended up creating a new selector and created all new settings.  Updated my DNS records with the new settings and all is good.

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums!
Don't forget to Like helpful posts and mark Solutions!
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.