Highlighted
Respected Contributor.
Respected Contributor.
982 views

Warning, after SLES upgrade, DKIM not working

After upgrading to the SLES version of SMG, I found that the opendkim service was not working. I have traced it back to the last entry in the opendkim.conf file which read SOCKET="inet:4932". This was correct on the Ubunto system, but on the sles system should be something like Socket inet:4932 or Socket inet:4932@localhost. The existing entry generates a configuration error on starting the service.

I have tried both options, which now start the opendkim service, but this service does not start on a boot and needs to be started manually, and it also does  not put the cert into the outgoing  email.

I have opened a service request with Micro Focus, and will report back on the outcome.

Regards

ChasR.

24 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Thanks for sharing.  I checked mine and realized I had the same problem.  I have opened an SR also.

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums within this community!
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

This is a defect and the developer staff is working on a fix.  I see that both of you have SRs.  You should have the workaround steps soon if not already.

Pam

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Thanks Pam!

--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums within this community!
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

We found this bug on Friday. DKIM isn't starting, because of this. This can easily be resolved by doing the following:

1) From a command prompt type: vi /etc/opendkim/opendkim.conf
 
2) Hit 'Insert'
 
3) Scroll down to line 765 and change it from SOCKET="inet:4932" to SOCKET net:4932@localhost (removing the quotes and =, adding a space after SOCKET, and adding @localhost)
 
4) Save changes by hitting 'esc' :wq
 
5) Start the opendkim service by typing: service opendkim start
 
6) To have it start automatically upon reboot type: systemctl enable opendkim.service
Then reboot the server.
 
DKIM should now start on it's own and work normally. This gets DKIM to run, but we are currently working on a bug to get DKIM signing to work. I will post an update here when it's fixed.
 
Sorry for the hassle this has caused.
Highlighted
Respected Contributor.
Respected Contributor.

Hi,

I have already tried this and although the opendkim will now start without errors, it still does not write the cert information into the email as it should (nothing is added). Also, I found that the service would not start automatically on a system power up and it was necessary to start the service manually.

Regards

ChasR.

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Thanks Chas.  I will make sure to update the tech assigned to you SR this morning so he can get back with you.

Pam

0 Likes
Highlighted
Super Contributor.
Super Contributor.

I'm having a similar problem.  Fix above allows DKIM service to start, however no DKIM header on email.  DKIM service also not starting automatically when VM is restarted.

I can open a support case also if it will help.

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

These other issues came to light as well. To get dkim to start upon reboot type:

systemctl enable opendkim.service

Then restart the server. The devs are currently working on getting DKIM signing to work however. Hopefully, we will have a fix soon.

 

Highlighted
Super Contributor.
Super Contributor.

Thank you Suzie!
Highlighted
Respected Contributor.
Respected Contributor.

Hi,

The systemctl command returns an error for me when I try it. I have found that if you go into yast and then services, the opendkim service is already there, but needs to be changed to start on boot, and can be started from there as well.

Make the changes here and save them, the service will then start as expected.

Regards

ChasR.

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

OK,
In the meantime there is version 7.0.0.59, which adds the missing DKIM header again.
However, there is still no update for the appliance via the SMG update channel and only an .ova can be downloaded from MFCC.
Can someone tell how an update can be carried out or is a new installation necessary?

regards
Thomas

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.