rodyan Absent Member.
Absent Member.
359 views

Defining custom attribute to mail template's recipient.


Hello everyone,

In a customer's setup, we're having a rough time at defining the
recipient's parameter in a Forgotten Password Verification template, so
when requested, it sends the notification to an email address that is
specified in a custom attribute. While there's no issue when we use the
standard "mail" attribute as a macro parameter; @User:Email@ (or even
@LDAP:mail), we can't find the way to put different attributes in such
macros (eg: @LDAP:alternativeMail@) to work.

Things checked:
* Mails are correctly sent (and received) when we switch values with the
alternative mail attribute and the standard Internet Email Address
attribute. (while @User:Email)
* Added the attribute's corresponding auxiliary class in SSPR's LDAP
Settings.
* Tried parameter calls such as @auxClass:alternativeMail@ with no
result.
* It's a fixed requirement, and unfortunately we can't just use the
standard mail attribute for this purpose.

Do you have any suggestions?

Thanks in advance.


--
rodyan
------------------------------------------------------------------------
rodyan's Profile: https://forums.netiq.com/member.php?userid=7717
View this thread: https://forums.netiq.com/showthread.php?t=53387

0 Likes
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: Defining custom attribute to mail template's recipient.

rodyan,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.netiq.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.netiq.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.netiq.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your NetIQ Forums Team
http://forums.netiq.com


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.