jlrodriguez Super Contributor.
Super Contributor.
970 views

SSO with HTTP Header

Hi,

I'm trying to do SSO with SSPR using the HTTP Header.

I defined the SSO Authenticaation Header Name ssoAuthUsername.

Going to "https://pwmds/sspr/public/ForgottenPassword?ssoAuthUsername=usertest5" I expect the user to be recognized and process the password recovery method, in this case, to have a Token sent by email.

I see at the catalina.out that the HTTP Header is recognized:
2017-05-01T12:29:00Z, TRACE, http.PwmRequest, {56l} GET request for: /sspr/public/ForgottenPassword [10.30.30.150]
ssoAuthUsername='usertest5'
2017-05-01T12:29:00Z, TRACE, http.PwmResponse, {56l} forwarding to /WEB-INF/jsp/forgottenpassword-search.jsp [10.30.30.150]

But instead of recognizing the user and continuing with the change procedure, appears the page that prompts to search for the user.

I trying also with the full DN of the user, but without success.

Regards
Jose Luis
0 Likes
1 Reply
AutomaticReply Absent Member.
Absent Member.

Re: SSO with HTTP Header

jlrodriguez,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.