Highlighted
skoehler Respected Contributor.
Respected Contributor.
603 views

SSPR 4.1.0.5 - Cancel-button for ../forgottenpassword

Hi there, would you call this a Feature or a bug?

It seems like there is something odd with the cancel-button on the /sspr/public/forgottenpassword page. It behaves the same as the search button (also returns error message username not found...)

What I would expect is to return to the SSPR Login page instead (so cancel the Feature call of forgotten Password because it just came back into my mind...)
Instead, a user has to retype the SSPR URL to get back to the Login page.


The html source says:

<button type="submit" name="button" class="btn" id="button-cancelButton" form="form-cancelButton">
<span class="btn-icon pwm-icon pwm-icon-times"></span>Cancel</button>

<form id="form-cancelButton" action="/sspr/public/forgottenpassword" method="post">
<input type="hidden" name="processAction" value="reset"/>
<input type="hidden" name="pwmFormID" value="lots of characters I'm not sure if they expose my Environment..."/>
</form>


The Action is defined in /opt/netiq/idm/apps/tomcat/webapps/sspr/WEB-INF/jsp/forgottenpassword-search.jsp with pwm:current-URL

Personally I'm not a friend of changing the jsp files due to Support reasons and hassles with updates.

How did you solve the issue or can you deal with the behavior?

Steffen
0 Likes
1 Reply
AutomaticReply Absent Member.
Absent Member.

Re: SSPR 4.1.0.5 - Cancel-button for ../forgottenpassword

skoehler,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.