gdrtx Absent Member.
Absent Member.

SSPR Config Error

I am trying to configure a new instance of SSPR on Red Hat Enterprise
Linux server with Apache Tomcat 7. The application starts up and is
accessible but as I go through the configuration screens I run into an
odd problem that I cannot resolve.

When I reach the step for "Response Storage Preference" I select my
choice (LDAP) and click the Next button. It doesn't go any where. The
screen flashes but then stays on that page. If I try to select another
option it does the same thing. If I try to click the Previous button it
does the same thing. The application gets "stuck" at this point and
will not move. If I let the session timeout I can start over but it
always stops at this screen no matter what my selection is. I have
noticed that if I click the Next button repeatedly that on occasion an
error will quickly flash on the screen in a black box before going away.
I have been able to capture the error which reads "error reaching
server. RequestError: Unable to load
ConfigGuide?processAction=updateForm&pwmFormID=<some long ID value>
status: 0"

Any ideas on what is going on there? I have uninstalled/reinstalled
SSPR and Tomcat to no avail. I have restarted tomcat several times with
no changes in behavior. When I put in the eDirectory server information
earlier in the setup it all succeeded fine.

gdrtx's Profile:
View this thread:

2 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: SSPR Config Error

A few checks:

1. Have you verified your sspr.war file, or wherever it originated, has
valid checksum per the download site?

2. Which version of SSPR? Are you trying with the latest patch,
preferably? I think is out now.

3. Which version of Java is powering Tomcat? I presume it's Sun/Oracle
Java, and not another distributor's (IBM, etc.). Is the version new
enough per the docs? I think the docs just say JDK 1.7, so probably okay
unless it's really old.

4. Have you tried installing on another instance of Tomcat to see if it
works there?

At the end of your post you mentioned something about eDirectory and
having it all work. Could you elaborate on that? Is the symptom
completely gone when you do something different? If you are using LDAP
(vs. eDirectory's Challenge Response stuff natively, or the LocalDB
option) for challenges, have you extended schema already in the
appropriate LDAP environment?

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
gdrtx Absent Member.
Absent Member.

Re: SSPR Config Error

Thanks but the issue ended up being a stupid user error. I looked at my
FF version and read as 36.1.2 and didn't realize it was an
unsupported version. After changing to a newer version everything
seemed to work ok.

gdrtx's Profile:
View this thread:

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.