Knowledge Partner
Knowledge Partner
1423 views

The requested redirect URL is not permitted?

Weird.

The docs state to use "this" when doing the forgotten password integration with NAM:

https://intranet.company.com/sspr/public/ForgottenPassword?forceAuth=TRUE&logoutURL=https://intranet.company.com/AGLogout


But for some reason in SSPR Version: v4.2.0.0 b196 r39220, Framework: 1.8.0
It gives the error:
SSPR 5075


The requested redirect url is not permitted.


It seems it doesn't like the last bit/part, which I don't understand why (ie: Lop off everything after the word TRUE, and it'll work).
Ironically the:
https://intranet.company.com/AGLogout
works as well (by itself)

So why doesn't it like them working together?

(obviously I have not published our URLs here)

It's something with the new appliance. The testbed appliance works fine (same version) with the same NAM instance.

But I can't find anything about the error (other than the useless KB that just lists the error codes with the same error), nor why it doesn't like the redirect for some weird reason.
0 Likes
1 Reply
Knowledge Partner
Knowledge Partner

Re: The requested redirect URL is not permitted?

kjhurni;2467172 wrote:
Weird.

The docs state to use "this" when doing the forgotten password integration with NAM:

https://intranet.company.com/sspr/public/ForgottenPassword?forceAuth=TRUE&logoutURL=https://intranet.company.com/AGLogout


But for some reason in SSPR Version: v4.2.0.0 b196 r39220, Framework: 1.8.0
It gives the error:
SSPR 5075


The requested redirect url is not permitted.


It seems it doesn't like the last bit/part, which I don't understand why (ie: Lop off everything after the word TRUE, and it'll work).
Ironically the:
https://intranet.company.com/AGLogout
works as well (by itself)

So why doesn't it like them working together?

(obviously I have not published our URLs here)

It's something with the new appliance. The testbed appliance works fine (same version) with the same NAM instance.

But I can't find anything about the error (other than the useless KB that just lists the error codes with the same error), nor why it doesn't like the redirect for some weird reason.


OK, so this error code results from the fact that the:

Settings -> Security -> Web Security -> Redirect Whitelist needs to have the:
https://yoursite.com/AGLogout

in there.

For some reason this is absent in the docs in the section where they tell you how to integrate it with NAM.

So I've submitted doc feedback.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.