Highlighted
Absent Member.
Absent Member.
2071 views

8.6: on looking up directory attributes

PROBLEM:
iexplore.exe (IE11) crashes on looking up an attribute in Active Directory.

EXAMPLE:
MessageBox "AD given name: " %givenName


ADD. INFORMATION:
from: NetIQ SecureLogin Application Definition Guide > Application definition variables > Types of Variables
https://www.netiq.com/documentation/securelogin-86/application_definition_guide/data/bk0ntmj.html


can anyone confirm?

thanks, florian

0 Likes
10 Replies
Highlighted
Absent Member.
Absent Member.

btw: crashes with all those usages:

MessageBox "AD phone number: " %telephoneNumber
MessageBox "not existing: " %notExistingAttribute
MessageBox "empty mobile: " %mobile

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Is it safe to assume these were all populated variables, and could you
share how?

Does this happen in the context of other applications (e.g. a plain text
editor) or only IE 11? Does it happen with other versions of IE, r on
other boxes?

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
Highlighted
Absent Member.
Absent Member.

Is it safe to assume these were all populated variables, and could you
share how?


no. only telephonenumber has a value.
doing the same with the not existing 'notExistingAttribute' or the empty 'mobile' attribute crashes IE as well.

since we have no other IE versions in production OR other browsers with securelogin integration but IE11 i only can confirm this (new) behaviour coming with 8.6.0.0. i can tell with certainty that 8.1.1.2 does not have any problems with these lookups.

8.1.1.2:
MessageBox "AD phone number: " %telephoneNumber
result: AD phone number: +387 93937 372

MessageBox "empty mobile: " %mobile
result: AD phone number:

MessageBox "not existing: " %notExistingAttribute
result: AD phone number:

8.6.0.0:
MessageBox "AD phone number: " %telephoneNumber
result: crash

MessageBox "empty mobile: " %mobile
result: crash

MessageBox "not existing: " %notExistingAttribute
result: crash

0 Likes
Highlighted
Absent Member.
Absent Member.

florianz;2481582 wrote:
PROBLEM:
iexplore.exe (IE11) crashes on looking up an attribute in Active Directory.

EXAMPLE:
MessageBox "AD given name: " %givenName


ADD. INFORMATION:
from: NetIQ SecureLogin Application Definition Guide > Application definition variables > Types of Variables
https://www.netiq.com/documentation/securelogin-86/application_definition_guide/data/bk0ntmj.html


can anyone confirm?

thanks, florian


Yes it's a bug in our product and we have a defect created for this for tracking(Bug 1095187)
0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

One of my co-workers reported similar problems with directory attribute variables running 8.6 with eDir via LDAP. When can we expect a fix to be released?

Regards,
Stefan
0 Likes
Highlighted
Absent Member.
Absent Member.

florianz;2481582 wrote:
PROBLEM:
iexplore.exe (IE11) crashes on looking up an attribute in Active Directory.

EXAMPLE:
MessageBox "AD given name: " %givenName


ADD. INFORMATION:
from: NetIQ SecureLogin Application Definition Guide > Application definition variables > Types of Variables
https://www.netiq.com/documentation/securelogin-86/application_definition_guide/data/bk0ntmj.html


can anyone confirm?

thanks, florian


I can confirm that.
By using Secure Login 8.6 with LDAP and IE Plugin for Web Application SSO. In Background is a OES with eDirectory

i cant using variables with "%". Only Systemvariables like ?sysuser are useable.

There is a big problem if you need a Company tag as Login and you cant use it.

Error : -107 Can not read Variable %
URL crash res://ieframe.dll/acr_error.htm#companyURL
0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

The Bug 1095187 fix will be available as part of 8.6 Hotfix 1 (8.6.0.1).
0 Likes
Highlighted
Absent Member.
Absent Member.

pvdinesh;2482778 wrote:
The Bug 1095187 fix will be available as part of 8.6 Hotfix 1 (8.6.0.1).


HI,

the Bug still exists. After 8.6 HF1 the IE doasnt crash anymore, but the %variables are empty and an ERROR BROKER_DS_VARIABLE_NOT_READ(-180) shows up (SR#101170494951).
0 Likes
Highlighted
Absent Member.
Absent Member.

DavidDD;2483902 wrote:
HI,

the Bug still exists. After 8.6 HF1 the IE doasnt crash anymore, but the %variables are empty and an ERROR BROKER_DS_VARIABLE_NOT_READ(-180) shows up (SR#101170494951).


HI,

I tried in my setup it works for me with NSL 8.6 HF1 in edir with LDAP. It shows correct common name for directory attribute variable '%cn', and full name for '%FULlNDSNAME'.

Can you share the script which you used?

Thanks
0 Likes
Highlighted
Absent Member.
Absent Member.

fixed with 8.6.1.0 (tested)

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.