Anonymous_User Absent Member.
Absent Member.
760 views

After Upgrade, all logins are Invalid


I have just "sucessfully" upgraded a server (a XEN VM) SLES10SP4 OES2 to
OES11 SP1, but when I check my secure login details, I now find that all
my logins are marked as invalid, so even though the secure login
(slproto & slbroker) are picking up all my logins, they are not
accessing the secure usernames and passwords associated with the logins.
The version running is the latest version 7 with all the patches, etc.
installed. Have checked edirectory and replica ring, and no problems
have presented themselves here.

Note: as the servers are VM's, I tried the version before the upgrade on
our test system, and the secure login was working fine, so it looks like
the upgrade has caused this problem.

Any help would be appreciated.

Regards

ChasR.


--
chas
------------------------------------------------------------------------
chas's Profile: https://forums.netiq.com/member.php?userid=4021
View this thread: https://forums.netiq.com/showthread.php?t=46599

0 Likes
5 Replies
Anonymous_User Absent Member.
Absent Member.

Re: After Upgrade, all logins are Invalid

chas wrote:

> Any help would be appreciated.


I have forward your concern to the support group. I will update this
thread when I learn more.

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: After Upgrade, all logins are Invalid


Thanks. I have made some changes since I posted this problem. I have
deleted the user's secret store, upgraded to 6.0 for the data store
(from 3.5), and checked the schema extensions for NDS and LDAP. I now
have a working system again, but only using NDS, as there are problems
with the secret store. If I try to use this method, I get the message
that secure login is unable to write to the secret store. I have tried
everything to correct this, and looked towards using the administration
program (ssscfg), which is aluded to in the Secure Login Documentation
for Linux, Solaris install. The problem I am now encountering is that
this particular program has been missed of the OES11 disc:- everything
else is there but no administration program. It looks like Novell have
made an oversight here, and I have ben unable to find it anywhere else
on the Internet.

Any ideas how to get the secret store to start accepting information
again?

Cheers,

ChasR


--
chas
------------------------------------------------------------------------
chas's Profile: https://forums.netiq.com/member.php?userid=4021
View this thread: https://forums.netiq.com/showthread.php?t=46599

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: After Upgrade, all logins are Invalid

chas wrote:

> Any ideas how to get the secret store to start accepting information
> again?


This is the response I had from my support contact. Does it help?


> Sounds like the problem is with SecretStore. Try using SecretStore
> Manager to diagnose the problem. You can download SSManger from here
> http://www.novell.com/support/kb/doc.php?id=7011696 Use SSManager to
> create a secret, read from secretstore, repair secretstore, retrieve
> SecretStore information, log problems with SecretStore, etc.
> Hopefully it will point us in the right direction.



--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: After Upgrade, all logins are Invalid


Thanks for getting back to me:- I have already tried to use secret store
manager, but it bombs out on me every time I try it. I think I will set
up an XP vm machine, with just the basics, and try using it from there
when I get a bit more time.

It seems that there is no easy, simple answer to the problem.

Cheers,

ChasR


--
chas
------------------------------------------------------------------------
chas's Profile: https://forums.netiq.com/member.php?userid=4021
View this thread: https://forums.netiq.com/showthread.php?t=46599

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: After Upgrade, all logins are Invalid

chas wrote:

>
> Thanks for getting back to me:- I have already tried to use secret
> store manager, but it bombs out on me every time I try it. I think I
> will set up an XP vm machine, with just the basics, and try using it
> from there when I get a bit more time.
>
> It seems that there is no easy, simple answer to the problem.
>
> Cheers,
>
> ChasR


Have you considered opening an SR?

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.