TipFlo Absent Member.
Absent Member.
1332 views

BROKER_NO_SUCH_VARIABLE(-112)

hi,

I have two sites handled in one application with almost identical loginmasks (only the Click # changes).


SetPrompt "Username:"
TextInput #1:1 -value "$Username"
SetPrompt "Passwort:"
TextInput #1:2 -value "$Password"
Click #4


If there is no username or password already stored then:
On one site it works fine (i get asked to input new Username and Password).
On the other site i get BROKER_NO_SUCH_VARIABLE(-112) Error, but if i interact with $username or $password in anyway beforhand and outside of the Sub it works.
For example if i first do:
If $Username Eq ""
EndIf
If $Password Eq ""
EndIf

I get asked to enter the variable $username and $Password

I use two Sub routines, one for each site, only difference in them is Click#4 changes to Click#2
The sites get detected correctly and call the correct Sub.
It works on both sites if the username and password have values in them.
The Sso Version is 8.1.1 Build2, but we are about to upgrade to 8.6.1, but from our testenvirement the site is not reachable.

Is there another solution other than keeping the workaround code in the application?
0 Likes
1 Reply
AutomaticReply Absent Member.
Absent Member.

Re: BROKER_NO_SUCH_VARIABLE(-112)

TipFlo,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.