Anonymous_User Absent Member.
Absent Member.
541 views

DisplayVariables won't display runtime variables


Or at least it's inconsistent. If I assign the value of $Username or
$Password to a local runtime variable DisplayVariables will display
that, and that alone. Attempting to display multiple runtime variables
(DisplayVariables "Please enter a new PIN and confirm it" ?NewPIN
?ConfirmPIN) doesn't display anything at all.

Is there some method to its use that's undocumented?

What I'm trying to do is simple:
1.) Have the user enter the current PIN, new PIN and confirm the new
PIN
2.) Perform a validation (either using a policy or in script) of the
new values
3.) Submit them to the application
4.) If the application reports success, to update $Password for the
application.

It's maddening. Any help understanding a method that I could accomplish
this is appreciated. I've figured out most or all of everything else
that I need to do.

Thanks, Jeff


--
jeff_stjohn
------------------------------------------------------------------------
jeff_stjohn's Profile: https://forums.netiq.com/member.php?userid=2222
View this thread: https://forums.netiq.com/showthread.php?t=42696

0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: DisplayVariables won't display runtime variables

jeff,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: DisplayVariables won't display runtime variables


I answered my own question. At least on Version 7.0.2 DisplayVariables
will ONLY display directory variables, and not either Runtime or local
variables. It doesn't matter whether or not they're set, or used within
the script. Disappointing.


--
jeff_stjohn
------------------------------------------------------------------------
jeff_stjohn's Profile: https://forums.netiq.com/member.php?userid=2222
View this thread: https://forums.netiq.com/showthread.php?t=42696

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.