Highlighted
BSChainarong
New Member.
968 views

Error installation SecureLogin with AA option enabled

Hi,

I am now working on SecureLogin with Advance Authentication and I found the error appeared during SecureLogin installation with AA option enabled.



If I ignore the error, SecureLogin can be installed successfully and working fine. However, I cannot use SecureLogin with AA since there is no endpoint registered in AA. There is a pop-up shown "Enpoint ID and Secret Information is missing....". Please see the following attached picture.



SecureLogin version is 8.5.0
AA version is 5.6

Thanks,
Chainarong
0 Likes
3 Replies
AutomaticReply Absent Member.
Absent Member.

Re: Error installation SecureLogin with AA option enabled

bschainarong,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
pvdinesh Absent Member.
Absent Member.

Re: Error installation SecureLogin with AA option enabled

Hi Chainarong,
The below issue looks to be something went wrong when SecureLogin tried connecting to AA server during installation.
SecureLogin + AA installation might fail
1. When AA server not reachable during SecureLogin installation.
2. Or any of the AA configuration details are incorrect
- IP
- Port
- Event name

Also, make sure you have .Net Framework 4.0 and above on your windows client.
https://www.netiq.com/documentation/securelogin-85/quick_start/data/quick_start.html#b17899ty

Regards,
Dinesh
0 Likes
pvdinesh Absent Member.
Absent Member.

Re: Error installation SecureLogin with AA option enabled

Furthermore to add, the issue looks like TLS 1.2 is not enabled on the Windows client machine.

By default, AA 5.6 supports only TLS 1.2 connection. You can check this by enabling TLS 1.0 in AA 5.6 Server.

Here is the link for the documentation to Enable TLS 1.0.
https://www.netiq.com/documentation/advanced-authentication-56/server-administrator-guide/data/configuring_policy.html
HTTPS Options#
==================================================
In this policy, you can configure settings to ensure that the appliance is safe from security vulnerabilities.

This policy allows you to configure the following two settings:

Enable TLS 1.0: It is recommended to keep this option disabled by default to ensure security vulnerabilities are prevented because TLS 1.0 is considered as an unsafe protocol. In some scenarios, you can enable the option to support the older versions of browsers. For more information on browser support for TLS, see TLS support for web browsers.

Enable HTTP compression: This setting allows you to enable the HTTP compression to accelerate performance in the scenarios of low bandwith or when the network connectivity is slow.
==================================================


After enabling TLS 1.0 in AA 5.6 Server, the NSL Installation should succeed with the Advanced Authentication Integration.

Note: TLS 1.2 support related bugs are fixed in NSL 8.5.1 release. So Please use NSL recent version 8.5.3.

Thanks,
Dinesh
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.