Anonymous_User Absent Member.
Absent Member.
810 views

NSL in AD-LDS environment


Hi guys,

I'm not familiar with AD-LDS (formerly known as ADAM) and I'm having
alot of problems getting NSL to work. I'm currently running 2 VMs: using
Windows Server 2008 32bit with AD-LDS installed and Windows XP 32bit for
end user workstation. After setting up the domain, creating the
instance, expending NSL scheme, setting the end user workstation to join
the domain, i keep getting this "You are not logged in to a directory.
SecureLogin was unable to find any cached user data." error. For a fresh
start, NSL should prompt me an empty passphrase form. Hope you guys can
help.


--
Ameera
------------------------------------------------------------------------
Ameera's Profile: http://forums.novell.com/member.php?userid=120428
View this thread: http://forums.novell.com/showthread.php?t=449866

0 Likes
5 Replies
Anonymous_User Absent Member.
Absent Member.

Re: NSL in AD-LDS environment

If you are adding the workstation to the domain it sounds like you are
running NSL in AD mode rather than LDAP (LDS/ADAM). Once you have
extended the schema you need to kake sure that the suers have rights to
the attributes. Occasionally this can seem to go slightly wrong. You
need to make sure that you run the schema extender "adsschema.exe" as
Administrator. Use the "Run As" option even if you are logged in as
Administrator.

Dave

On 21/12/2011 02:56, Ameera wrote:
>
> Hi guys,
>
> I'm not familiar with AD-LDS (formerly known as ADAM) and I'm having
> alot of problems getting NSL to work. I'm currently running 2 VMs: using
> Windows Server 2008 32bit with AD-LDS installed and Windows XP 32bit for
> end user workstation. After setting up the domain, creating the
> instance, expending NSL scheme, setting the end user workstation to join
> the domain, i keep getting this "You are not logged in to a directory.
> SecureLogin was unable to find any cached user data." error. For a fresh
> start, NSL should prompt me an empty passphrase form. Hope you guys can
> help.
>
>

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NSL in AD-LDS environment


Hi Dave,

I've already tried your suggestion but the prompt is still there. Is it
not recommended to run this AD-LDS as AD for NSL?

David Guest;2162853 Wrote:
> If you are adding the workstation to the domain it sounds like you are
> running NSL in AD mode rather than LDAP (LDS/ADAM). Once you have
> extended the schema you need to kake sure that the suers have rights
> to
> the attributes. Occasionally this can seem to go slightly wrong. You
> need to make sure that you run the schema extender "adsschema.exe" as
> Administrator. Use the "Run As" option even if you are logged in as
> Administrator.
>
> Dave
>
> On 21/12/2011 02:56, Ameera wrote:
> >
> > Hi guys,
> >
> > I'm not familiar with AD-LDS (formerly known as ADAM) and I'm having
> > alot of problems getting NSL to work. I'm currently running 2 VMs:

> using
> > Windows Server 2008 32bit with AD-LDS installed and Windows XP 32bit

> for
> > end user workstation. After setting up the domain, creating the
> > instance, expending NSL scheme, setting the end user workstation to

> join
> > the domain, i keep getting this "You are not logged in to a

> directory.
> > SecureLogin was unable to find any cached user data." error. For a

> fresh
> > start, NSL should prompt me an empty passphrase form. Hope you guys

> can
> > help.
> >
> >



--
Ameera
------------------------------------------------------------------------
Ameera's Profile: http://forums.novell.com/member.php?userid=120428
View this thread: http://forums.novell.com/showthread.php?t=449866

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NSL in AD-LDS environment

If you want to use LDS (ADAM) you need to make sure that you run the AD
prep first them run the ADAM prep. This makes the attributes available.
You then install NSL in LDAP mode giving it the IP/DNS address of the
LDS server. It sounds like one of the steps has gone wrong.

Dave

On 22/12/2011 06:56, Ameera wrote:
>
> Hi Dave,
>
> I've already tried your suggestion but the prompt is still there. Is it
> not recommended to run this AD-LDS as AD for NSL?
>
> David Guest;2162853 Wrote:
>> If you are adding the workstation to the domain it sounds like you are
>> running NSL in AD mode rather than LDAP (LDS/ADAM). Once you have
>> extended the schema you need to kake sure that the suers have rights
>> to
>> the attributes. Occasionally this can seem to go slightly wrong. You
>> need to make sure that you run the schema extender "adsschema.exe" as
>> Administrator. Use the "Run As" option even if you are logged in as
>> Administrator.
>>
>> Dave
>>
>> On 21/12/2011 02:56, Ameera wrote:
>>>
>>> Hi guys,
>>>
>>> I'm not familiar with AD-LDS (formerly known as ADAM) and I'm having
>>> alot of problems getting NSL to work. I'm currently running 2 VMs:

>> using
>>> Windows Server 2008 32bit with AD-LDS installed and Windows XP 32bit

>> for
>>> end user workstation. After setting up the domain, creating the
>>> instance, expending NSL scheme, setting the end user workstation to

>> join
>>> the domain, i keep getting this "You are not logged in to a

>> directory.
>>> SecureLogin was unable to find any cached user data." error. For a

>> fresh
>>> start, NSL should prompt me an empty passphrase form. Hope you guys

>> can
>>> help.
>>>
>>>

>
>

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NSL in AD-LDS environment


Have you synchronized the right OU's to AD-LDS? If you have users in
several different OU's you need to synchronize all of them. At least be
sure that the user you're using belongs to a right synchronized OU.

David Guest;2163216 Wrote:
> If you want to use LDS (ADAM) you need to make sure that you run the AD
> prep first them run the ADAM prep. This makes the attributes
> available.
> You then install NSL in LDAP mode giving it the IP/DNS address of the
> LDS server. It sounds like one of the steps has gone wrong.
>
> Dave
>
> On 22/12/2011 06:56, Ameera wrote:
> >
> > Hi Dave,
> >
> > I've already tried your suggestion but the prompt is still there. Is

> it
> > not recommended to run this AD-LDS as AD for NSL?
> >
> > David Guest;2162853 Wrote:
> >> If you are adding the workstation to the domain it sounds like you

> are
> >> running NSL in AD mode rather than LDAP (LDS/ADAM). Once you have
> >> extended the schema you need to kake sure that the suers have

> rights
> >> to
> >> the attributes. Occasionally this can seem to go slightly wrong.

> You
> >> need to make sure that you run the schema extender "adsschema.exe"

> as
> >> Administrator. Use the "Run As" option even if you are logged in

> as
> >> Administrator.
> >>
> >> Dave
> >>
> >> On 21/12/2011 02:56, Ameera wrote:
> >>>
> >>> Hi guys,
> >>>
> >>> I'm not familiar with AD-LDS (formerly known as ADAM) and I'm

> having
> >>> alot of problems getting NSL to work. I'm currently running 2 VMs:
> >> using
> >>> Windows Server 2008 32bit with AD-LDS installed and Windows XP

> 32bit
> >> for
> >>> end user workstation. After setting up the domain, creating the
> >>> instance, expending NSL scheme, setting the end user workstation

> to
> >> join
> >>> the domain, i keep getting this "You are not logged in to a
> >> directory.
> >>> SecureLogin was unable to find any cached user data." error. For a
> >> fresh
> >>> start, NSL should prompt me an empty passphrase form. Hope you

> guys
> >> can
> >>> help.
> >>>
> >>>

> >
> >



--
vesapi
------------------------------------------------------------------------
vesapi's Profile: http://forums.novell.com/member.php?userid=73631
View this thread: http://forums.novell.com/showthread.php?t=449866

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NSL in AD-LDS environment


vesapi;2164203 Wrote:
> Have you synchronized the right OU's to AD-LDS? If you have users in
> several different OU's you need to synchronize all of them. At least be
> sure that the user you're using belongs to a right synchronized OU.


Yes. I did miss one step. Thanks guys. 🙂


--
Ameera
------------------------------------------------------------------------
Ameera's Profile: http://forums.novell.com/member.php?userid=120428
View this thread: http://forums.novell.com/showthread.php?t=449866

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.