tfechner Absent Member.
Absent Member.
875 views

Report compilation with SDK 1.8


Hello,

is it possible to compile new reports with these software versions:
iReport: 5.6
JAVA_VERSION="1.8.0_31"
JAVA_SDK: "1.8.0_31"
JRE 8, and JDK 8,

Creating a new report with Eclipse and trying to make a development
build I get these messages:

Code:
--------------------

...
[javac] C:\Daten\EclipseWorkspace\Sentinel-SDK\current\sdk\build\build-reports.xml:209: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
[jasperc] Compiling 3 report design files.
....
[jasperc] File : C:\Daten\EclipseWorkspace\Sentinel-SDK\content\build\Report\VKB_Audit-DB_2011.1r1\plugin\TemplateChart.jrxml ... FAILED.
[jasperc] Error compiling report design : C:\Daten\EclipseWorkspace\Sentinel-SDK\content\build\Report\VKB_Audit-DB_2011.1r1\plugin\TemplateChart.jrxml
[jasperc] net.sf.jasperreports.engine.JRException: Errors were encountered when compiling report expressions class file:
[jasperc] 1. The type java.lang.CharSequence cannot be resolved. It is indirectly referenced from required .class files
[jasperc] /*
[jasperc] ^
[jasperc] 1 errors
....
[echo] 2015-5-12 Report compilation failed : Errors were encountered when compiling report designs.

BUILD FAILED


--------------------


Torsten


--
tfechner
------------------------------------------------------------------------
tfechner's Profile: https://forums.netiq.com/member.php?userid=8929
View this thread: https://forums.netiq.com/showthread.php?t=53473

0 Likes
3 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Report compilation with SDK 1.8

A few things:

I'm not sure that even Sentinel 7.3 (unless with its latest patch) is up
to Java 1.8. As a result, any .class files (or related, so probably
..jasper files) created will probably not run because of an incompatibility
in what the older (1.7) JRE can run.

I do not believe this is tested yet, because of the above.

Ideally you'll probably have a better chance of finding the answer in the
plugin-sdk forum; in fact this came up recently in this thread over there:

https://forums.netiq.com/showthread.php?t=52674

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
hitanjan Absent Member.
Absent Member.

Re: Report compilation with JAVA 1.8 / JRE 8 ?


Hi,

Here is a manual workaround -

Download and copy 'this jar' (http://tinyurl.com/mxtpfqp) under this
particular folder structure - *_.../current/sdk/build/lib/compilejars_*
in your local copy of the Sentinel SDK.
That should temporarily fix the compilation errors you are observing in
your development environment.


--
hitanjan
------------------------------------------------------------------------
hitanjan's Profile: https://forums.netiq.com/member.php?userid=7927
View this thread: https://forums.netiq.com/showthread.php?t=53473

0 Likes
tfechner Absent Member.
Absent Member.

Re: Report compilation with JAVA 1.8 / JRE 8 ?


thank yuo - will try later - I switched to the discontinued version 1.7.
- compilation works in this version.


--
tfechner
------------------------------------------------------------------------
tfechner's Profile: https://forums.netiq.com/member.php?userid=8929
View this thread: https://forums.netiq.com/showthread.php?t=53473

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.