Knowledge Partner
Knowledge Partner
540 views

Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors

Hi.

"Zypper patch", as documented, throws a dependency error right now
between sentinel_server_7000_x86_64-update-0.2010.0-4.noarch and grub.

Precisely, sentinel_server_7000_x86_64-update-0.2010.0-4.noarch requires
grub = 0.97.162.168.25, but this dependency cannot be provided.

The version of grub shown *is* actually the currently installed one, but
"zypper patch" wants to install a newer one.

Oddly, a regular "zypper up" (vs zypper patch as documented) does not
give a dependency error.

Maybe someone wants to check the repos.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
10 Replies
ScorpionSting Absent Member.
Absent Member.

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors


Are you trying to update an appliance with the tar.gz file? If so, this
is not supported.

You will need to contact NTS for a link to the ISO version for the
appliance, or wait until later this month when 7.4 is released in the
update channel.


--
-"Also now available in 'G+'
(http://plus.google.com/+BenWalter-Kiwi) and 'Website'
(https://www.isam.kiwi/) format".- 😉
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=54809


Visit my Website for links to Cool Solution articles.
0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors


I just checked our appliance that I upgraded with ISO....it ended up
with:


Code:
--------------------
novell-SentinelSI-base-7.3.2.0-2101
novell-SentinelSI-db-7.3.2.0-2101
novell-Sentinelbase-SLES-7.3.2.0-2101
novell-Sentinelcontent-addon-7.3.2.0-2101
novell-Sentinelcontent-base-7.3.2.0-2101
novell-Sentineldb-SLES-7.3.2.0-2101
novell-Sentinelindexer-7.3.2.0-2101
novell-Sentineljms-7.3.2.0-2101
novell-Sentineljre-7.3.2.0-2101
novell-Sentinelnetflow-api-7.3.2.0-2101
novell-Sentinelnetflow-installer-7.3.2.0-2101
novell-Sentinelnfdump-7.3.2.0-2101
novell-Sentinelrest-services-7.3.2.0-2101
novell-Sentinelsce-installer-7.3.2.0-2101
novell-Sentinelscm-installer-7.3.2.0-2101
novell-Sentinelserver-7.3.2.0-2101
novell-Sentinelsidb-indexer-connector-7.3.2.0-2101
novell-Sentinelsm-bridge-7.3.2.0-2101
novell-Sentinelsolutionpacks-7.3.2.0-2101
novell-Sentinelwebapp-7.3.2.0-2101
novell-Sentinelwebserver-7.3.2.0-2101
sentinel_server_7000_x86_64-release-0.623.0-0
sentinel_server_7000_x86_64-update-0.877.0-1
supportutils-plugin-sentinel-1.0.1-7.1
--------------------


I did cheat with a test Sentinel I had....it was appliance and I was
using tar.gz.....I got the same dependency error, but ended up just
removing that package and its related one, then the install happened....

You could also try:


Code:
--------------------
zypper dup
--------------------


This is a distribution update and will upgrade everything to the latest
available packages....it might be better at getting past the dependency


--
-"Also now available in 'G+'
(http://plus.google.com/+BenWalter-Kiwi) and 'Website'
(https://www.isam.kiwi/) format".- 😉
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=54809


Visit my Website for links to Cool Solution articles.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors

Am 07.12.2015 um 21:54 schrieb ScorpionSting:
>
> Are you trying to update an appliance with the tar.gz file? If so, this
> is not supported.


No, I'm trying to update an appliance using zypper and the online repos.

> You will need to contact NTS for a link to the ISO version for the
> appliance, or wait until later this month when 7.4 is released in the
> update channel.


Well, anyways. Updating the appliance (wteher it's 7.3.2 or not) throws
a dependency error.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors


The repo doesn't have 7.3.2, just 7.3.1.....they won't update it with
7.4 just around the corner....

Do a dup when 7.4 is released and see if your issue magically
disappears....


--
-"Also now available in 'G+'
(http://plus.google.com/+BenWalter-Kiwi) and 'Website'
(https://www.isam.kiwi/) format".- 😉
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=54809


Visit my Website for links to Cool Solution articles.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors

Am 08.12.2015 um 02:24 schrieb ScorpionSting:
>
> The repo doesn't have 7.3.2, just 7.3.1.....they won't update it with
> 7.4 just around the corner....


Saw that now here in the forums, but frankly, apart from this being a
bad decision, it needs to be in the readme and the docs. Seriously.

> Do a dup when 7.4 is released and see if your issue magically
> disappears....


But I have a customer appointment to work on and fix some of their
sentinel issues (some of which are fixed in 7.3.2) now and not sometime
later.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors


Log an NTS request for access to the appliance ISO...

Remove the old one from "yast repositories" and add/enable the
downloaded one. Disable the online repo. Do a "zypper dup" and you'll be
good to go... Just don't forget to reenable the online repo when they
release 7.4


--
ScorpionSting
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=54809


Visit my Website for links to Cool Solution articles.
0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors


Oh, to speed things up, supply your NetIQ login id in SR - so they can
add you for access...then they'll email you the download link


--
-"Also now available in 'G+'
(http://plus.google.com/+BenWalter-Kiwi) and 'Website'
(https://www.isam.kiwi/) format".- 😉
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=54809


Visit my Website for links to Cool Solution articles.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors

Am 08.12.2015 um 11:24 schrieb ScorpionSting:
>
> Oh, to speed things up, supply your NetIQ login id in SR - so they can
> add you for access...then they'll email you the download link


Thanks, SR open for a while.

Nonetheless (not targeted at you of course), this really needs to be in
the readme of 7.3.2...) There's rumours some weird customers don't read
this forum. 😉

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors


David often keeps his eye on this forum.....he might take this onboard
for the next time there is a short release cycle where the online repo
isn't updated.


--
-"Also now available in 'G+'
(http://plus.google.com/+BenWalter-Kiwi) and 'Website'
(https://www.isam.kiwi/) format".- 😉
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=54809


Visit my Website for links to Cool Solution articles.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Sentinel 7.3.1 update to 7.3.2 via zypper gives dependency errors

Am 07.12.2015 um 15:01 schrieb Massimo Rosen:
> Hi.
>
> "Zypper patch", as documented, throws a dependency error right now
> between sentinel_server_7000_x86_64-update-0.2010.0-4.noarch and grub.


FWIW, disregard this part please. A coworker fubared, the conflicting
grub version isn't in the channels, my bad.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.