Frequent Visitor..
Frequent Visitor..
72 views

Agent upgrade fails with examine command failed lockfail

Multiple servers have successfully completed a Device Migrations from 10.21 mesh to a 2018.08 mesh. However, when trying to upgrade the agent to the version for the 2018.08 several of the Linux 5/6 server yield the "EXAMINE: command failed (LOCKFAIL)" error message. This similar to a old issue with Windows servers, that was resolved by removing the "persisto" file. However, I don't find that find on the Linux systems.

I have tested a few to removed and then install the new agent and it works, so it's not disk space, firewall ports or other things that might prevent the new agent from working. It seems like there is something that fails some locking or eval step early in the upgrade process. Some fail with "STAGE command failed (ABORTED)".

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.