Commander
Commander
4145 views

SA 10.50 installation error

Jump to solution

Hi Experts,

AS i 'm trying to install SA 10.50 by invoking 'hpsa_install.sh' it giving error.

Please help me in this.

SA error.png

Any help will be highly appreciated.

Tags (1)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

It looks like you're starting the hpsa_install.sh script while being positioned in a directory called "Desktop".

You must be positioned in the "/" directory when you're starting hpsa_install.sh. So do something like this:

 

[root@localhost Desktop] # cd /
[root@localhost /] # <path_to_hpsa_install.sh>/hpsa_install.sh

The documentation mentions this, in the Install_Guide.pdf, for example in section SA Core Installation -> Installing SA Core with a local SA-supplied database -> Phase 1: Preparing to install the SA Core:

 

3. On the server where you will install SA, mount the following media: Product Software (primary),
the Agent and Utilities media (upload) and the Oracle_SA (oracle_sas), or NFS-mount a directory
that contains a copy of the media contents.
a. Open a terminal window and log in as a user with root permissions.
b. Change to the root directory: cd /

View solution in original post

14 Replies
Micro Focus Expert
Micro Focus Expert

It looks like you're starting the hpsa_install.sh script while being positioned in a directory called "Desktop".

You must be positioned in the "/" directory when you're starting hpsa_install.sh. So do something like this:

 

[root@localhost Desktop] # cd /
[root@localhost /] # <path_to_hpsa_install.sh>/hpsa_install.sh

The documentation mentions this, in the Install_Guide.pdf, for example in section SA Core Installation -> Installing SA Core with a local SA-supplied database -> Phase 1: Preparing to install the SA Core:

 

3. On the server where you will install SA, mount the following media: Product Software (primary),
the Agent and Utilities media (upload) and the Oracle_SA (oracle_sas), or NFS-mount a directory
that contains a copy of the media contents.
a. Open a terminal window and log in as a user with root permissions.
b. Change to the root directory: cd /

View solution in original post

Commander
Commander

HI @adrian_fita Thanks for reply.

I tried placing the media in 'opt' directory and accesing it by root. i get the same result.

PLease check the attached file.

its been around 3 days that i'm struck here.

0 Likes
Micro Focus Expert
Micro Focus Expert

Like I said above, you need to be positioned in the root ("/") directory before starting hpsa_install.sh.

In the screenshot you're not positioned in /.

Do the command "cd /" before starting hpsa_install.sh.

Commander
Commander

Hi @adrian_fita yes it works.

But now i struck again . Please check the screenshot and try to help.

0 Likes
Micro Focus Expert
Micro Focus Expert

You do not have the nfs packages installed.

If you're installing on a RedHat distro, install them with "yum install nfs-utils".

Check the Install_Guide.pdf for Installation requirements, most likely you don't have other things too so you'll get stuck many times. See the section "System requirements for installation" from Install_Guide.pdf.

Commander
Commander

@adrian_fitayes its going as you said.

I would like to know few more things, as i'm going to install SA on production please let me know below things:

1. what is the current version, i guess 10.50?

2. which package i need to install for production .(i have single server in production)

3. is there any prequisiter checker i can run before the installation?

Please help me in this as i'm new in this tool.

Any help will be highly appreciated.

0 Likes
Micro Focus Expert
Micro Focus Expert

1. the latest available release is 10.50. 10.60 will be published very soon (couple of weeks).

2. I don't understand this question. What do you mean by "package"? You mean what edition of Server Automation to install?

3. The prerequisites are checked by the Server Automation's installer itself. Also read the documentation, Install_Guide.pdf, section "System requirements for installation".

Commander
Commander

@adrian_fitayes edition?

also please tell what is  SA core, SA satellite and SA slice i'm getting confude b/w them.

and one more can we install SA on VM in production?

please help in this.

0 Likes
Micro Focus Expert
Micro Focus Expert

also please tell what is  SA core, SA satellite and SA slice i'm getting confude b/w them.

You'll have to read the documentation about these. The forum is no place for basic training.

and one more can we install SA on VM in production?

Yes, you can install SA in VM.

Commander
Commander

@adrian_fitaThanks for your suggestion.

AS now i'm getting error in installation library.Please check attached screenshotand help.lib_error.png

0 Likes
Micro Focus Expert
Micro Focus Expert

The messages in the errors look straightforward and they indicate to solutions about how to solve them.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.