Absent Member.. tcsullens Absent Member..
Absent Member..
2066 views

SA Agent Linux Install Failing

I'm running into a problem trying to use the SA client to install the agent to some linux boxes in my environment, specifically Red Hat 6.5 VMs. 

When running the "Install SA Agent" job, I get a prequisite check error right after the SSH session has connected:

Could not check temporary directory accessibility.

 

And of course the install fails. I can do the remote agent install to Windows servers just fine.

I attached an image of the error / job.

 

I'm not doing anything crazy / wierd here; the remote directory it should be copying to is /tmp, the user creds are fine, file ACLs are fine. As far as I can tell this is only happening with remote agent install on my RHEL infrastructure.

 

Anyone have any suggestions? Like somewhere that may have more verbose logs of the job?

0 Likes
5 Replies
Probirdas Respected Contributor.
Respected Contributor.

Re: SA Agent Linux Install Failing

Hi ,

 

 

I hope you are installing with ROOT access. it should be root account.

 

You can try as below

====================

1.Try to do install with root account ,  if it fails go for second step

2.Try to change another directory as temp, if it fails go for third step

3.Try to do installl manually for testing purpose 

opsware-agent-45.0.47353  --opsw_gw_addr <HPSA core IP>:3001 --force_full_hw_reg --force_sw_reg --logfile "\logfile9.txt" --loglevel trace

 

 

I hope , it will be helpful

 

Regards,

Uday

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: SA Agent Linux Install Failing

If /tmp is mounted Read-Only or with the NOEXEC option you will get that error.

I'm guessing its noexec mounted.

 

Brett

Absent Member.. tcsullens Absent Member..
Absent Member..

Re: SA Agent Linux Install Failing

I know this is like 2 months after the fact, but just wanted to follow up and say the issue remains a mystery.

/tmp is fine, the agent will install fine when done locally. There's just some sort of issue with the remote deployment of the agent and the error I showed above seems more generic than anything... Any guru want to point me to where the actual script is on the core that does this remote agent install?

 

There is a deploy agent script, but from looking at it I'm not sure that is the same one that is being run for remote agent install.

0 Likes
sebastian_orbai Absent Member.
Absent Member.

Re: SA Agent Linux Install Failing

That is the deploy script, you should give it a try, but as stated before you should check the permissions of that machine.
0 Likes
Absent Member.. Jesse2 Absent Member..
Absent Member..

Re: SA Agent Linux Install Failing

Did you ever get to the bottom of this?  I'm seeing the same thing trying to perform the remote agent installation.  RHEL 7 now, for what its worth.  I'm using credentials that can SSH and sudo.  I don't like the recommendation that you must use the root user.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.