Micro Focus Frequent Contributor
Micro Focus Frequent Contributor
463 views

(SA) Support Tip: Avoid installing the OPSWpytwist ZIP package against an HPSA infra, slice, or sat

Installing the OPSWpytwist ZIP package onto an infra, slice, or sat server can cause various different errors.

This can cause several different kind of failure modes. One specific failure mode is that if the newly upgraded HPSA 10.5x mesh is put into TLSv1.2 mode, and the version of OPWpytwist ZIP that is installed was from 10.2x or earlier, then the new 10.5x hub will fail to start with the following error:

fw-rules.py cannot fetch getDefaultHubGid from the twist.

The hub startup script using pytwist to connect to the twist, and this connectivity will fail as in the following example that reveals the deeper error. (This error is obcured when attempting to start HPSA.)

# env PYTHONPATH=/opt/opsware/pylibs2 /opt/opsware/bin/python2 -c 'import pytwist;print pytwist.twistserver.TwistServer("localhost")._makeCall("fido/ejb/session/UserFacade","getDefaultHubGid",())'
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/opt/opsware/pylibs2/pytwist/twistserver.py", line 235, in _makeCall
ctx=self.ctx, gw_list=self.to_use_gw_list)
File "./urlopen.py", line 278, in httpUrlRequest
File "./asyncssl.py", line 106, in connect
File "./asyncssl.py", line 143, in _connect_inner
File "./asyncssl.py", line 254, in ssl_connect
File "./asyncssl.py", line 272, in _timeout_io
M2Crypto.SSL.SSLError: ('error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol', 336032002)

If the OPSWpytwist ZIP package is installed onto an HPSA core or satellite server, it will conflict with the built-in OPSWpytwist RPM. The ZIP version of the package contains source files and the RPM contains only the pyc complied python files. It is intended for use on regular managed servers.

When the mesh is them upgraded, the OPSWpytwist RPM will be upgraded, but the python source files from the OPSWpytwist ZIP file will remain. If the timestamp of those python source files is newer than the newly upgraded pyc compiled python files, then the newer python compiled files will be overwritten by the older OPSWpytwist ZIP source files.

Contact HPSA support for guidance in recovering from this problem.

(Source: https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/KM02784118)

Labels (1)
0 Replies
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.