Vice Admiral Vice Admiral
Vice Admiral
241 views

(SA) Support Tip: How to fix the error "ConnectionPool lcrep: all connections in use" in vault logs

If an SA mesh experiences a large number of transactions that are not sent/received between the SA cores you can check the vault logs under /var/log/opsware/vault/ for the following error message:

[com.opsware.omb.db.ConnectionPool] [waitForConnection] ConnectionPool lcrep: all connections in use

This error message will occur if the database pool of connections is completely used and the vault is waiting for an available connection.

You may increase the number of available connections by following these steps:

1. Edit the vault configuration file on each SA infrastructure server:

/etc/opt/opsware/vault/vault.conf

2. Add/Modify the parameter com.opsware.omb.dbpool.poolSize (it is missing by default) and set the pool size to 20 (or more):

com.opsware.omb.dbpool.poolSize=20

3. Restart the master gateway and the vault after the change:

/etc/init.d/opsware-sas restart opswgw-mgw vaultdaemon

For more information please refer to the following knowledge document:

https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/KM1447622

Micro Focus Customer Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Labels (1)
0 Likes
0 Replies
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.