toomas_aas Absent Member.
Absent Member.
1954 views

AMIE import from ZCM 11.3 to SD 7.0.3

Has anyone successfully done AMIE import from ZCM 11.3? I'm trying it with Service Desk 7.0.3 and not succeeding.

My AMIE settings:

Type: "Zenworks Configuration Management 11.1 - Hardware" (have also tried "Zenworks Configuration Management 11.1", with same results).

Database type: Sybase Anywhere (my ZCM is using the embedded Sybase database)

Host: hostname of my ZCM server
Port: 2638
Name: zenworks_
Usename and Password: as obtained with 'zman dgc' on the ZCM server
Schema: dbo
Catalog: zenworks_

When I click 'Test', the result is successful. However, when I run Import, it ends with result:
Item import failed An error occurred whilst reverse engineering the remote schema Check the database connection details, and refer to the log file for further information

Log file has the following further information:
2014-07-10 11:11:27,586]ERROR166767[LiveTimeScheduler_Worker-3] (DynamicDbComms.java:303) - An error occurred whilst initializing Comms: An unknown error occurred during the schema extraction - no tables were found
java.lang.Exception: An unknown error occurred during the schema extraction - no tables were found
at com.livetime.assetmgmt.dynamicdb.HbmParser.parseXML(HbmParser.java:265)
at com.livetime.assetmgmt.DynamicDbComms.generateSchema(DynamicDbComms.java:588)
at com.livetime.assetmgmt.DynamicDbComms.initCollection(DynamicDbComms.java:294)
at com.livetime.assetmgmt.AssetImportMgr.importAssets(AssetImportMgr.java:235)
at com.livetime.assetmgmt.AssetImportJob.run(AssetImportJob.java:142)
at com.livetime.service.AssetImportService.execute(AssetImportService.java:72)
at org.quartz.core.JobRunShell.run(JobRunShell.java:213)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557)
0 Likes
6 Replies
toomas_aas Absent Member.
Absent Member.

Re: AMIE import from ZCM 11.3 to SD 7.0.3

Don't know why I assumed that default settings for database name, schema and catalog are correct for Sybase. They are not, and correct settings can be found in the docs:
Name: zenworks
Schema: zenadmin
Catalog: zenworks

After setting these correctly, import succeeded
0 Likes
elphantasmo Absent Member.
Absent Member.

Re: AMIE import from ZCM 11.3 to SD 7.0.3

Yes, I successfully imported ZCM 11.3 into NSD 7.0.3. Unfortunately, I didn't use a template nor was there enough correct/useful info in Zenworks to make it useful. I ended up disconnecting the Zen in Amie and deleted the whole import. Short story is, it works.
0 Likes
hfr63 Absent Member.
Absent Member.

Re: AMIE import from ZCM 11.3 to SD 7.0.3

We had to do a domain name change. So instead of trying to move the old ZENworks server to the new domain since we were also upgrading to Windows 7 on the workstations, I created a new ZENworks server in the new domain. We did migrate the Service Desk server over to the new domain instead of building from scratch. When I connect up to the SQL database (also on the new domain) within AMIE and I test the connection, I get "Successfully connected to the External Asset Management System". BUT when I try to perform an import, I get "Item import failed. An error occurred whilst reverse engineering the remote schema. Check the database connection details..." The log file shows:
[2015-03-16 03:00:00, 195] ERROR376575 [LiveTimeScheduler_Worker-5] (DynamicDbComms. java:300) - An error occurred whilst initializing Comms: Error while reading column meta data for 'zenworks_ZCM-TASC'.dbo.LC_TallyProdReconcileMap
org.hibernate.exception.JDBCConnectionException: Error while reading column meta data for 'zenworks_ZCM-TASC'.dbo.LC_TallyProdReconcileMap

When I log onto the SQL Server and check the zenworks_ZCM-TASC database, dbo.LC_TallyProdReconcileMap is listed under Tables

Anyone have any clues?
0 Likes
rsankar1 Absent Member.
Absent Member.

Re: AMIE import from ZCM 11.3 to SD 7.0.3

In NSD 7.0.3 you should not get this error. 7.0.1/7.0.2 doesn't support ZENworks 11.3.x. Can you confirm your NSD version?

Thanks
Sankar R
0 Likes
BMcDowell1 Absent Member.
Absent Member.

Re: AMIE import from ZCM 11.3 to SD 7.0.3

I am getting errors with ZCM 11.3.0 (not the appliance, but using hte embedded Sybase) and NSD 7.1. I've tried importing via the AMIE process and the ZENworks import process - same results, mounting frustration.

Bruce McDowell Technical Services Consultant, McDowell Consulting LLC bruce@consultbruce.com
0 Likes
padharsh1 Absent Member.
Absent Member.

Re: AMIE import from ZCM 11.3 to SD 7.0.3

The below doc has details on AMIE ZENworks and NSD 7.1. On which step are you seeing the problem
https://www.novell.com/documentation/servicedesk71/help71/Administrator/importing_items_using_zenamie.htm
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.