Highlighted
Absent Member.
Absent Member.
2161 views

How to configure Novell Service Desk Chat feature

I have been unsuccessful in finding information on how to get the Chat feature to work - other then enabling it in the Privileges tab. The user is able to initiate the Chat and NSD technician is able to receive it but there is no text being received, only that there is a Chat in the queue, Chat windows are empty. Below is the error message displayed by Google Chrome.

Uncaught SyntaxError: Unexpected token ) 54.0.53.21.4.1.0.1.1.1.4.1.0.3.0.1.1.4.1.3.3.1.1.1.0.0.1.0:14
POST http://snlsd1.sargentlundy.com/LiveTime/WebObjects/LiveTime.woa/wa/ChatAction/getChat chat.js:60
POST http://snlsd1.sargentlundy.com/LiveTime/WebObjects/LiveTime.woa/wa/ChatAction/openChat chat.js:18
POST http://snlsd1.sargentlundy.com/LiveTime/WebObjects/LiveTime.woa/wa/ChatAction/sendChat chat.js:70
Uncaught SyntaxError: Unexpected token )

🙂

thx in advance!
0 Likes
5 Replies
Highlighted
Absent Member.
Absent Member.

0i2585,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Hi,

We are using the chat function but we are working with IE and/or Firefox. Maybe give them a try.

Good luck
0 Likes
Highlighted
Absent Member.
Absent Member.

wjterveld;2298137 wrote:
Hi,

We are using the chat function but we are working with IE and/or Firefox. Maybe give them a try.

Good luck


Thank you for responding but I have tried the latest version of IE including Firefox, no luck so far. I have also noticed that other static links, such as the reset password and trying to view an existing request will error. I have a feeling I have to go into the Linux side and modify some file, perhaps char.js., wouldn't know what to modify, add or deleted.
0 Likes
Highlighted
Absent Member.
Absent Member.

If you configured Setup->Privileges->System->Host Address wrongly(with out port) then the chat feature won't work as expected. Give a try by removing the entry from Host Address, it is an optional field.
0 Likes
Highlighted
Absent Member.
Absent Member.

Since no one responded I ended up opening an SAR with Novell - just last week we finally got to the bottom of the problem. You are correct the problem is in the Host address field in Setup->Privileges->System - the entire address had to be removed from the field and left blank. None of the other address configurations worked and it does not state that this is an optional field. So it begs the question, "what is it for?". Thanks for responding!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.