Highlighted
Absent Member.. Absent Member..
Absent Member..
1129 views

9.41 New Install Errors - Unsupported Java Version

Good Morning,

 

I just installed 9.4, then ran the upgrade to 9.41.  I am using Java version 1.8.0_51 and I am getting the following errors in the logs when starting the HP Service Manager Service.   I have 2 other environments where service manager is functioning correctly with the exact same version of Java.  I am wondering how I can fix this issue?

 

Joe

 

2968( 1844) 10/29/2015 11:32:48 RTE I Process sm 9.41.0020 () System: 13080 (0x784DFB00) on PC (x64 64-bit) running Windows (6.2 Build 9200) Timezone GMT-06:00 daylight Locale en_US from hpsm94-prd
2968( 1844) 10/29/2015 11:32:48 RTE I Creating resources for system '13080' with key 0x784DFB00
2968( 1844) 10/29/2015 11:32:48 RTE I Created shared memory of size 134217728 using key 0x784DFB00 and attached to it at address 0x80000000
2968( 1844) 10/29/2015 11:32:48 RTE I JVM successfully created
2968( 1844) 10/29/2015 11:32:48 JRTE I Java version: 1.8.0_51
2968( 1844) 10/29/2015 11:32:48 RTE E Unsupported Java version: 1.8.0_51
2968( 1844) 10/29/2015 11:32:48 RTE E Please install or setup Java 7 correctly!
2968( 1844) 10/29/2015 11:32:48 RTE E HP Service Manager is unable to start. Failed to initialize or attach to shared memory environment
2968( 1844) 10/29/2015 11:32:48 RTE E Failed Initializing Java.
2968( 1844) 10/29/2015 11:32:48 RTE I Shutdown of HP Service Manager environment has completed
2968( 1844) 10/29/2015 11:32:48 RTE I -Memory : S(60976) O(107388) MAX(324268) - MALLOC's Total(1592)
2968( 1844) 10/29/2015 11:32:48 RTE I Thread termination in progress
2968( 1844) 10/29/2015 11:32:48 RTE I Process termination cleanup complete (exit code=1)
2380( 1084) 10/29/2015 11:32:53 RTE I smservice: starting process sm system.start
752( 1392) 10/29/2015 11:32:53 RTE I Using "utalloc" memory manager, mode [0]
752( 1392) 10/29/2015 11:32:53 RTE I Command line: sm system.start
752( 1392) 10/29/2015 11:32:53 RTE I Process sm 9.41.0020 () System: 13080 (0x784DFB00) on PC (x64 64-bit) running Windows (6.2 Build 9200) Timezone GMT-06:00 daylight Locale en_US from hpsm94-prd
752( 1392) 10/29/2015 11:32:53 RTE I Creating resources for system '13080' with key 0x784DFB00
752( 1392) 10/29/2015 11:32:53 RTE I Created shared memory of size 134217728 using key 0x784DFB00 and attached to it at address 0x80000000
752( 1392) 10/29/2015 11:32:53 RTE I JVM successfully created
752( 1392) 10/29/2015 11:32:53 JRTE I Java version: 1.8.0_51
752( 1392) 10/29/2015 11:32:53 RTE E Unsupported Java version: 1.8.0_51
752( 1392) 10/29/2015 11:32:53 RTE E Please install or setup Java 7 correctly!
752( 1392) 10/29/2015 11:32:53 RTE E HP Service Manager is unable to start. Failed to initialize or attach to shared memory environment
752( 1392) 10/29/2015 11:32:53 RTE E Failed Initializing Java.
752( 1392) 10/29/2015 11:32:53 RTE I -Memory : S(61056) O(107308) MAX(324268) - MALLOC's Total(1594)
752( 1392) 10/29/2015 11:32:53 RTE I Thread termination in progress
752( 1392) 10/29/2015 11:32:53 RTE I Shutdown of HP Service Manager environment has completed
752( 1392) 10/29/2015 11:32:53 RTE I Process termination cleanup complete (exit code=1)
2380( 1084) 10/29/2015 11:32:58 RTE I smservice: initialization complete

0 Likes
2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: 9.41 New Install Errors - Unsupported Java Version

Did you delete

9.41/Server/RUN/lib and 9.41/Server/RUN/jre before you installed SM9.41 Server ?

If you are not sure or if you want to correct this, please follow these steps:

1. Stop SM 9.41 service

2. rename 9.41/Server/RUN/lib directory to lib_OLD

3. rename 9.41/Server/RUN/jre directory to jre_OLD

4. locate in your downloads the sm9.41.0020_Windows_Server.zip, unzip this

5. locate in the unzipped sm9.41.0020_Windows_Server/RUN directory the directories lib and jre

6. copy the directories lib and jre to your SM9.41/Server/RUN directory

7. clear sm.log file

8. Start Service Manager 9.41 service

 

I hope this helps.

 

Thank you for using the MicroFocus ServiceManager Support and News Forum. If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: 9.41 New Install Errors - Unsupported Java Version

Re-read the Installation guide. I also took the shortcut and just copied the data into the RUN folder, but you must delete the tomcat, lib & jre folders first before you copy.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.