Respected Contributor.. Bjorn Kihlberg Respected Contributor..
Respected Contributor..
356 views

Anyone running Smart Analytics (Smart Search) in 9.51?

Jump to solution
Hi,

We are upgrading from 9.40 to 9.51 on Windows. I have installed Smart Analytics and most of the libraries in Smart Search is working fine. But I am struggling with the indexing of some webpages: the pages require a Windows domain logon and I am not sure if I have succeeded in setting up the Windows authentication correctly in the \HTTPconnector\httpconnector.cfg file. I used to get the message *unauthorized (401)* in the syncronize.log but after submitting my credenrials in httpconnector.cfg and restarting the http connector service, the *unauthorized(401)* message is gone. But still the webpage is not indexed.

Any ideas?

\björn
0 Likes
1 Solution

Accepted Solutions
Respected Contributor.. Bjorn Kihlberg Respected Contributor..
Respected Contributor..

Re: Anyone running Smart Analytics (Smart Search) in 9.51?

Jump to solution

I found that this is the way to set up windows authentication to enable the IDOL spider to craw a web page secured by a login: you need to supply the domain details as well as the username

in blue

 

(from httpconnector.cfg)

DIRECTORY=MY NOTES DATABASE
CantHaveCSVs=*.css,*.js
CantHaveCheck=1
//BJKI02 set to False
StayOnSite=False
Depth=99
//Bjorn - allowed smaller pages since Notes pages sometimes are small
MINPAGESIZE=0
//ProxyHost=PROXY.COM
//ProxyPort=80
//Bjorn - picked up these two parameters from the HTTP Connector help files
FollowRobotProtocol=false
FollowRobotMeta=false
//----Login with form----
//LOGINMETHOD=FORMPOST
//LOGINURL=https://login.com/
//LOGINUSERFIELD=os_username
//LOGINUSERVALUE=USERNAME@COMPANY.COM
//LOGINPASSFIELD=os_password
//LOGINPASSVALUE=PASSWORD_ENCRYPTED
//LoginSubmitField=ButtonID
//----HTTP digest authentication----
//DigestUsername=USERNAME
//DigestPassword=PASSWORD_ENCRYPTED
//----NTLM authentication----
//NTLMUsername=user
//NTLMPassword=pass
//Bjorn -  some Notes databases requires logon - add you windows account to the proper AD group
//Bjorn -  you need to supply your credentials below to avoid the error message 'Unauthorized (401).'
NTLMUsername=< my domain >\< my userid >
NTLMPassword=< my password >

0 Likes
2 Replies
Micro Focus Expert
Micro Focus Expert

Re: Anyone running Smart Analytics (Smart Search) in 9.51?

Jump to solution

Did you check the status of the HTTP Connector in the Smart Search configuration page? If so, what is the status?

Did you add a weblib library in the Smart Search configuration in SM after adding your credentials in the cfg file (if this wasn't already added previously)?

Did you perform a Full Reindex on that library (if this wasn't done previously)?

If you already checked all of the areas above, it would probably help if you provide the logs from IDOL server (or at least the ones showing any current errors), as well as the .cfg file for review.

Please note: If the site you are trying to index is a Sharepoint site the steps will be different than the ones above. You can find more details in the SM Help Center.

If you find that this or any other post resolves your issue, please remember to click "Accept as Solution". If you are satisfied with anyone’s response, please remember to give them KUDOS by clicking on the "thumbs up" at the bottom left of the post to show your appreciation.
Respected Contributor.. Bjorn Kihlberg Respected Contributor..
Respected Contributor..

Re: Anyone running Smart Analytics (Smart Search) in 9.51?

Jump to solution

I found that this is the way to set up windows authentication to enable the IDOL spider to craw a web page secured by a login: you need to supply the domain details as well as the username

in blue

 

(from httpconnector.cfg)

DIRECTORY=MY NOTES DATABASE
CantHaveCSVs=*.css,*.js
CantHaveCheck=1
//BJKI02 set to False
StayOnSite=False
Depth=99
//Bjorn - allowed smaller pages since Notes pages sometimes are small
MINPAGESIZE=0
//ProxyHost=PROXY.COM
//ProxyPort=80
//Bjorn - picked up these two parameters from the HTTP Connector help files
FollowRobotProtocol=false
FollowRobotMeta=false
//----Login with form----
//LOGINMETHOD=FORMPOST
//LOGINURL=https://login.com/
//LOGINUSERFIELD=os_username
//LOGINUSERVALUE=USERNAME@COMPANY.COM
//LOGINPASSFIELD=os_password
//LOGINPASSVALUE=PASSWORD_ENCRYPTED
//LoginSubmitField=ButtonID
//----HTTP digest authentication----
//DigestUsername=USERNAME
//DigestPassword=PASSWORD_ENCRYPTED
//----NTLM authentication----
//NTLMUsername=user
//NTLMPassword=pass
//Bjorn -  some Notes databases requires logon - add you windows account to the proper AD group
//Bjorn -  you need to supply your credentials below to avoid the error message 'Unauthorized (401).'
NTLMUsername=< my domain >\< my userid >
NTLMPassword=< my password >

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.