Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..
388 views

Current Approvals are not displaying on Approvals Tab

Jump to solution

In PD Current Approvals list is empty in second phase once you submitted a change. Initial it is working fine but I don't know what happend- now it's not working I did some analsis but unable to find the solutation.

If I added approver in first phase it's fine but only thing is not working insecond phase.

Thanks in advance

Screen attached

0 Likes
1 Solution

Accepted Solutions
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Current Approvals are not displaying on Approvals Tab

Jump to solution

Issue fixed.....

Eecently we updated cm3r "object". We noticed some changes in Approvals tab settings

Recalculated approvals if : evaluate(approvalsRecalc in $L.wfPhase)

Reset approvals if: not  (same(current.phase in $L.file, current.phase in $L.file.save)) or evaluate(approvalsReset in $L.wfPhase)

it's working fine now.... Thanks for the responce

Reddy

View solution in original post

0 Likes
4 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Current Approvals are not displaying on Approvals Tab

Jump to solution

Are the Approvals being set or not?

If the Approvals are not being set when you configure then on second phase, check your approval conditions. Check the approval definition conditions and make sure it's in the phase you want. If you are in doubt about the condition itself, add a "true or " at the beggining and see if it sets it. If it works your conditions is with some problem.. if does not work well... it's worse 🙂

If the approvals are being set but they are not appearing in the format, check the VJ. compare the format and links of each phase.

Regards,
Breno Abreu

If you feel this was helpful please click the KUDOS! thumb below!
0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Current Approvals are not displaying on Approvals Tab

Jump to solution

I already checked every link and format control and also checked with condations. I did some research before coming to this foru......I deleted this workflow and created new forkflow and assigned to same category but still same issue.....

Except this category every other category approvals are working fine

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Current Approvals are not displaying on Approvals Tab

Jump to solution
But you didn't provide any further information I asked you about.. Just telling it does not work will not help us to help you.
Are the approvals beings set? You can check directly on the Approval table. If not, attache the print from your flow where you are setting the approval definition and another of your Approval definition.
Regards,
Breno Abreu

If you feel this was helpful please click the KUDOS! thumb below!
0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Current Approvals are not displaying on Approvals Tab

Jump to solution

Issue fixed.....

Eecently we updated cm3r "object". We noticed some changes in Approvals tab settings

Recalculated approvals if : evaluate(approvalsRecalc in $L.wfPhase)

Reset approvals if: not  (same(current.phase in $L.file, current.phase in $L.file.save)) or evaluate(approvalsReset in $L.wfPhase)

it's working fine now.... Thanks for the responce

Reddy

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.