Highlighted
mistfit Absent Member.
Absent Member.
804 views

Error message 71 when trying to send data to HPSM via php

Jump to solution

Hi Experts

Unfortunately I am an absolute beginner with SOAP/HPSM API/PHP implementation, so I hope I can express myself well anyways.

I created a webform with php that should send the input to our HPSM to create an incident more easily. Right now I am trying to let the webform communicate with the HPSM API.

By now I have the following php code:

<?php
    $wsdl ='http://asdf/HPSMIntegrationAPI?wsdl';
    $client = new SoapClient($wsdl, array('login' => "asdf",
                                          'password' => "asdf",
                                          'trace'=> 1));

    $request = array(
        //'SubmitIntApiIncidentRequest'=>array(
            'model'=>array(
                'keys'=>array(),
                'instance'=>array(
                    'registrationID' => 'A40E5CA7-F1C0-CAD4-B89C-C2B91692468E',
                    'contactId' => 'contactid',
                    'affectedUserId' => 'affuserid',
                    'serviceId' => 'serviceid',
                    'affectedCiId' => '',
                    'priority' => '4',
                    'title' => 'Test',
                    'description' => 'First test with soapclient.php',
                    'submittedBy' => 'submitid',
                    'assignmentGroup' => 'assignmentgroup',
                    'externalReferenceId' => '',
                    'category' => 'Incident',
                    'resolveImmediately' => ''
        )));
 
    $response = $client->SubmitIntApiIncident($request);
    print_R($response);

 
?>

When I open my soapclient.php with a browser I get the following error message:

.........g ) [category] => stdClass Object ( [_] => Incident [type] => String ) [resolveImmediately]
=> stdClass Object ( [_] => [type] => Boolean ) [uniquequery] => id=NULL ) ) [messages]
=> stdClass Object ( ) [status] => FAILURE [message] => Validation failed [schemaRevisionDate]
=> 2017-02-04 [schemaRevisionLevel] => 0 [returnCode] => 71 )

Can anyone help me what the error message means and what I should change in my code that it works?

Thank you very much

Kind regards

Tim

Tags (5)
0 Likes
1 Solution

Accepted Solutions
mistfit Absent Member.
Absent Member.

Re: Error message 71 when trying to send data to HPSM via php

Jump to solution

I can't believe it, but I could solve the problem myself: In the php-code I wrote "registrationID" instead of "registrationId" - now it works.

0 Likes
3 Replies
mistfit Absent Member.
Absent Member.

Re: Error message 71 when trying to send data to HPSM via php

Jump to solution

I can't believe it, but I could solve the problem myself: In the php-code I wrote "registrationID" instead of "registrationId" - now it works.

0 Likes
ALARMus Acclaimed Contributor.
Acclaimed Contributor.

Re: Error message 71 when trying to send data to HPSM via php

Jump to solution
mistfitI wrote "registrationID" instead of "registrationID"
But it's same
0 Likes
mistfit Absent Member.
Absent Member.

Re: Error message 71 when trying to send data to HPSM via php

Jump to solution

Yes, sorry for that. I now edited the reply, so you can see the difference.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.