Absent Member.
Absent Member.
488 views

F1 help on web field not displaying

Hi pleae could I get some advice on this issue.  I have added a field to the sd form and need to add some field context help.  I have added the field in the help table in system definitions and accepted the help, it displays on the client with cntl H but not the web with F1, all the original fields display the field context help correctly in both client and web, but not the new field.  Any advice would be great.  thanks.

 

sm9.21 win2k8r2

 

0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

I can think  of 2 possibilities. 1) webtier cache still storing old version. Clear the tomcat cache and see if thats the reason.

2) I recalled for some sm version, the F1 key did not work unless used together with CTRL or SHIFT key.

0 Likes
Absent Member.
Absent Member.

Need to use Shift+F1 after keeping focus on desired field.

 

____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
0 Likes
Absent Member.
Absent Member.

 

Hi Thanks for the advice, however the issue is that I can get the help to display in a full client but not on the web client.   I have created a new field on the sd form which displays the new help on the sd.open.interaction but not on the sd.update.interaction for the web client.  I have added a new row duplicating the original that works for the sd.open.interaction into the help.g for the form SD.update.interaction but the web help still doesn't display.  Any advice would be greatly appriciated

0 Likes
Micro Focus Expert
Micro Focus Expert

If you are referring to the debug help info and not just the description, that functionality was not added till SM 9.33+.

If you are not even getting the description on the web client, try browsers that are not IE. IE11 seem to have lots of issues.

0 Likes
Absent Member.
Absent Member.

Hi no is the answer to the last question.  I'm talking about the F1 help description for each field on a form  I'm on sm9.21 which has this function.  I can get it displaying in the full client ok but not completely on the web which is quite frustrating.  I have sd.open and sd.update I've added a new field which is displaying correctly, but f1 help on the sd.update form doesn't display in the web, the f1 help only displays on the sd.open form on the web.  I have duplicated the help entry to make one for the open form and one for the update form but this doesn't resolve the issue.  any ideas?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.