Highlighted
Absent Member.. Absent Member..
Absent Member..
4270 views

HP Service Manager 9.34 - Branding is not working

Jump to solution

Hello,

 

I've recently installed HP Service Manager 9.34. 
I'm trying to use the "Branding" feature but I'm always getting the following error message:

"Branding is not enabled correctly".

 

Does anybody knows how to overcome this error?
Is there a specific place to enable the branding feature?

Thanks in advance for your help!

Best Regards,

Filipe Cruz

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.. Absent Member..
Absent Member..

You need to define the directory for the  Branding files.

 

To specify the location for the branding files, follow these steps:

  1. Stop the web application server.

  2. Specify the folder location in Web parameter: customize-folder.

    For example:

    <context-param>
      <param-name>customize-folder</param-name>
      <param-value>C:/customize</param-value>
    </context-param>

    Tip: To apply the branding settings from one web tier to another, copy the customize-folder you specified from the source web tier to the target web tier.

  3. On the web tier host, create a folder (for example, C:\customize) . This folder is the root folder to store your branding image files, including your custom image files to replace the original ones and your branding settings in the branding menu. In this folder, Service Manager saves your color and font settings in a branding.xml file and custom images in a subfolder named branding-images.

    Note: You must have write access to this folder.

  4. Restart the web application server. 

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...

View solution in original post

10 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

You need to define the directory for the  Branding files.

 

To specify the location for the branding files, follow these steps:

  1. Stop the web application server.

  2. Specify the folder location in Web parameter: customize-folder.

    For example:

    <context-param>
      <param-name>customize-folder</param-name>
      <param-value>C:/customize</param-value>
    </context-param>

    Tip: To apply the branding settings from one web tier to another, copy the customize-folder you specified from the source web tier to the target web tier.

  3. On the web tier host, create a folder (for example, C:\customize) . This folder is the root folder to store your branding image files, including your custom image files to replace the original ones and your branding settings in the branding menu. In this folder, Service Manager saves your color and font settings in a branding.xml file and custom images in a subfolder named branding-images.

    Note: You must have write access to this folder.

  4. Restart the web application server. 

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...

View solution in original post

Highlighted
Absent Member.. Absent Member..
Absent Member..
Hello John,

Thanks for your help. It worked perfectly! 🙂

Best Regards!

Filipe
0 Likes
Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..

How do i turn branding on and change it! I have looked for documentation and cant find it!

 

 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

The branding interface is new with release 9.34. Are you running 9.34 applications?

 

If you upgraded an existing system to 9.34 and had previously modified the HOME menu, if you kept the old version of the HOME menu instead of the new one, you may not see the Branding menu item.

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Branding works fine for me.

But I'm tryining to overstear some HPSM images.

According to the  branding guide I have to create the same folder structure within the "Branding Folder".

 

For example I would like to customize the following images:

[webtier]\images\obj16\context.png

 

Therefore I put the new image into the following folder:

[branding-folder]\images\obj16\context.png

 

I deleted the tomcat work content. I deleted my browser cache. I restarted the webtier.

It's not working for me.

Does it work for anyone out there?

 

 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

The instructions a for the image path are incorrect. 

 

The correct path is:

[branding folder]/branding_images

 

You would then place your images directly in that folder. You do not need to use any subfolder (e.g. obj16). Then use the branding interface to select those images to replace the OOB images for the logo, etc. 

 

It looks like you're trying to update images other than those included in the branding interface: I don't believe that is supported.  The branding interface does not replace any and all icons/images you enter. I don't think replicating the obj16 directory to overwrite OOB images in that directory will work.

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
0 Likes
Highlighted
Contributor.. Contributor..
Contributor..

Hi All,

 

My hp-logo.jpg  (Main Page Header logo )is very big in size say 998X91 pixels ,how can i put this .

 

The actual size is 22X22 and I need to change this is 998X91 .

 

As per the branding guide i have modified  the webtier.less  like below but it is not working 

 

.masthead-logo {
margin: 4px 15px 4px 15px;
height: 22px;
cursor: pointer;
img {
width: initial !important;
height: 22px !important;
}
}

 

Kindly help.

 

Regrads,

Shameer

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hey Guys,

 

I'm having an issue because my web tier is on Linux. How should I proceed on that case?

 

Thank you,

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

I found the solution for my webtier been on Linux/Unix:

 

- you need to use the full path when document you directory in the customize folder parameter

- it is required to give access to Tomcat or the user that is running the tomcat service to write on the directory (my case I did "chmod 777 <customize folder>")

 

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.
It helped me with version 9.63.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.