Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
720 views

HPSM LDAP to Service Manager Web Services - Contact and CI Creation

Jump to solution

Hi Experts,

I have currently configure a Connect-IT (9.60) situation to populate the Contacts and some CIs in HPSM (9.40), it is all ready to go, works perfect in "Test Mode". (LDAP Connector -> Mapping -> Service Manager Web Service)

When I run it in Production Mode, I get the following errors, when creating the contacts on HPSM Web Service side:

2016/09/26 14:55:38.000 0 1 (0) Unable to initialize request.
2016/09/26 14:55:38.000 0 1 (0) Error processing query.
2016/09/26 14:55:38.000 1 1 (0) Cause by com.hp.ov.cit.connector.ws.WsException: SOAP error when sending SOAP message.
2016/09/26 14:55:38.000 2 1 (0) Cause by org.apache.axis2.AxisFault: A CXmlApiException was raised in native code : error 4 : scxmlapi(4) - Missing or invalid XML document

Is anyone familiar with this error and what the resolution is to it? It seems there is some error in a XML document somewhere, which could be causing the Soap Error.

In http.log, I see the following errors:

5936( 2432) 09/26/2016 10:29:05.347 HttpLog: session ID has not been set yet.
5936( 2432) 09/26/2016 10:29:05.347 HTTP/1.1 500

Thanks

0 Likes
1 Solution

Accepted Solutions
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

It appears that this error is directly related to the Mapping portion of the Connect-IT Scenario, I discovered this while playing with a different CIT  scenario and I was missing a field which threw the previous error of: 

2016/09/26 14:55:38.000 0 1 (0) Unable to initialize request.
2016/09/26 14:55:38.000 0 1 (0) Error processing query.
2016/09/26 14:55:38.000 1 1 (0) Cause by com.hp.ov.cit.connector.ws.WsException: SOAP error when sending SOAP message.
2016/09/26 14:55:38.000 2 1 (0) Cause by org.apache.axis2.AxisFault: A CXmlApiException was raised in native code : error 4 : scxmlapi(4) - Missing or invalid XML document

So I attempted changing some of the fields in my original CIT Scenario Mappings which resolved the error.

View solution in original post

0 Likes
1 Reply
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

It appears that this error is directly related to the Mapping portion of the Connect-IT Scenario, I discovered this while playing with a different CIT  scenario and I was missing a field which threw the previous error of: 

2016/09/26 14:55:38.000 0 1 (0) Unable to initialize request.
2016/09/26 14:55:38.000 0 1 (0) Error processing query.
2016/09/26 14:55:38.000 1 1 (0) Cause by com.hp.ov.cit.connector.ws.WsException: SOAP error when sending SOAP message.
2016/09/26 14:55:38.000 2 1 (0) Cause by org.apache.axis2.AxisFault: A CXmlApiException was raised in native code : error 4 : scxmlapi(4) - Missing or invalid XML document

So I attempted changing some of the fields in my original CIT Scenario Mappings which resolved the error.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.